Permalink
Browse files

netatalk: resolved conflict with libevent, added cracklib support option

Netatalk builds by default its own version of libevent and upon
installation replaces libevent system files. That is fixed by
adding libevent dependency and appropriate configuration options.
Also an option for cracklib support has been added.
  • Loading branch information...
1 parent 9400587 commit d9febb8cd9738c83e35e9bfc6d809ec5b268c515 elh committed with v4hn Oct 7, 2012
Showing with 9 additions and 1 deletion.
  1. +2 −0 net/netatalk/CONFIGURE
  2. +6 −0 net/netatalk/DEPENDS
  3. +1 −1 net/netatalk/DETAILS
@@ -0,0 +1,2 @@
+OPTS="--with-libevent-header=/usr/include --with-libevent-lib=/usr/lib"
+echo 'OPTS='\"$OPTS\" >> $MODULE_CONFIG
@@ -1,4 +1,5 @@
depends db
+depends libevent
depends libgcrypt
optional_depends "avahi" \
@@ -10,3 +11,8 @@ optional_depends "Linux-PAM" \
"--with-pam" \
"--without-pam" \
"for PAM support"
+
+optional_depends "cracklib" \
+ "--with-cracklib=/usr/share/cracklib" \
+ "--without-cracklib" \
+ "for cracklib support"
@@ -5,7 +5,7 @@
SOURCE_VFY=sha1:6bea839c0e6a6e09e72fe35324a0edda3f7494f4
WEB_SITE=http://netatalk.sourceforge.net/
ENTERED=20121003
- UPDATED=20121004
+ UPDATED=20121006
SHORT="Open Source AFP fileserver."
cat << EOF

0 comments on commit d9febb8

Please sign in to comment.