Permalink
Browse files

webkit: Version bump to 1.8.3. Compiles with sockets, spell and webgl.

  • Loading branch information...
1 parent 636ff6c commit e7a378fd94653eca1bb97d6c3a7765c15901e127 stumbles committed Dec 30, 2012
Showing with 8 additions and 3 deletions.
  1. +4 −0 web/webkit/BUILD
  2. +1 −0 web/webkit/DEPENDS
  3. +3 −3 web/webkit/DETAILS
View
@@ -1,6 +1,10 @@
(
+
patch_it $SOURCE2 1 &&
+
+ sedit "s:wtf/Complex.h:complex.h:" Source/WebCore/platform/audio/FFTFrame.cpp Source/WebCore/webaudio/RealtimeAnalyser.cpp Source/WebCore/platform/audio/Biquad.h &&
+
OPTS+=" --with-target=x11 \
--with-unicode-backend=icu \
--with-font-backend=freetype \
View
@@ -17,6 +17,7 @@ depends Switch
#optional_depends "gst-plugins-good" "--enable-video" "--disable-video" "for HTML5 video support"
depends "gst-plugins-good"
+optional_depends "%JAVA_SDK" "--enable-jit" "--disable-jit" "for jit support"
optional_depends "geoclue" "--enable-geolocation" "--disable-geolocation" "for geolocation support"
optional_depends "gobject-introspection" "--enable-introspection" "--disable-introspection" "say Y for Epiphany, and possibly others"
optional_depends "librsvg" "--enable-svg --enable-svg-fonts" "--disable-svg" "for svg graphics support"
View
@@ -1,16 +1,16 @@
# WHEN BUMPING THIS MODULE PLEASE CHECK IF ANY OF THE COMMENTED
# BUILD OPTIONS IN CONFIGURE/DEPENDS WORK AGAIN!
MODULE=webkit
- VERSION=1.8.2
+ VERSION=1.8.3
SOURCE=$MODULE-$VERSION.tar.xz
SOURCE2=webkit-bison-2.6.patch
SOURCE_URL=http://www.webkitgtk.org/releases/
SOURCE2_URL=$PATCH_URL/
- SOURCE_VFY=sha1:138f86894e0a7ed0a41c18c4ac30fcaf961d8d79
+ SOURCE_VFY=sha1:ccf567fdfd7fbc63a3340777278e41b17522b80d
SOURCE2_VFY=sha1:18c5611095a3d105d8ee02357dd6fb729c1eb86a
WEB_SITE=http://www.webkit.org
ENTERED=20070919
- UPDATED=20120803
+ UPDATED=20121229
SHORT="gtk+ web rendering engine"
cat << EOF

0 comments on commit e7a378f

Please sign in to comment.