Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

ghostscript: Adding a CONFIGURE to allow enabling of the omni print d…

…river.

Adjusting the DEPENDS, ghostscript prefers lcms2.
Adjusting the BUILD to remove the source provided lcms2 and adding to OPTS
--with-install-cups so it will install some of its conversion tools.
  • Loading branch information...
commit e8970d4778a82aec2be0fb08d2a0b270e0f8d308 1 parent 23fa7d8
stumbles authored
View
4 printer/ghostscript/BUILD
@@ -3,9 +3,9 @@
# Remove local libs so we'll always use system libs,
# and don't waste configure / compile time on them.
verbose_msg "Removing unneeded local libs" &&
- rm -rf expat freetype jasper jbig2dec jpeg{,xr} lcms libpng tiff zlib &&
+ rm -rf expat freetype jasper jbig2dec jpeg{,xr} lcms{,2} libpng tiff zlib &&
- OPTS+=" --disable-compile-inits --enable-dynamic --with-system-libtiff LIBS=-lz" &&
+ OPTS+=" --disable-compile-inits --enable-dynamic --with-system-libtiff LIBS=-lz --with-install-cups" &&
# Will run ./configure with Lunar's options, in default_build
sedit "s:\$srcdir/configure:echo:" autogen.sh &&
View
2  printer/ghostscript/CONFIGURE
@@ -0,0 +1,2 @@
+mquery ENABLE_OMNI "Enable the omni print driver?" y "--with-omni" "--without-omni"
+
View
2  printer/ghostscript/DEPENDS
@@ -1,7 +1,7 @@
depends %JPEG
depends libpng
depends tiff
-depends lcms
+depends lcms2
optional_depends "jasper" \
"--with-jasper" \
Please sign in to comment.
Something went wrong with that request. Please try again.