Skip to content
This repository
Browse code

mplayer2: Remove optional dependency for live555

Live555 support in mplayer2 is currently broken due to a API change
in live555 a while back.
  • Loading branch information...
commit f9d0735da987ef63c6ceeba083dd7a69f7e89f7a 1 parent 172c833
Stefan Wold authored October 07, 2012
3  video/mplayer2/BUILD
@@ -16,6 +16,9 @@
16 16
     EXTRA_LIBS_MPLAYER+=" -lX11 -lXext"
17 17
   fi
18 18
 
  19
+  # Since live555 2012 the API has changed and mplayer2 haven't fixed it yet
  20
+  OPTS+=" --disable-live"
  21
+
19 22
   ./configure  --target=$BUILD                              \
20 23
                --prefix=/usr                                \
21 24
                --confdir=/etc                               \
1  video/mplayer2/DEPENDS
@@ -17,5 +17,4 @@ optional_depends "libtheora"     "" "--disable-theora"     "for OggTheora suppor
17 17
 optional_depends "freetype2"     "" "--disable-freetype"   "for FreeType 2 font rendering"
18 18
 optional_depends "fontconfig"    "" "--disable-fontconfig" "for fontconfig font lookup"
19 19
 optional_depends "libdvdread"    "" "--disable-dvdread"    "for dvdread support"
20  
-optional_depends "live555"       "" "--disable-live"       "for LIVE555 Streaming Media support (RTP/RTSP)"
21 20
 optional_depends "cdparanoia"    "" "--disable-cdparanoia" "for cdparanoia support"
2  video/mplayer2/DETAILS
@@ -7,7 +7,7 @@
7 7
          ENTERED=20110330
8 8
          UPDATED=20110330
9 9
            SHORT="A movie and animation player"
10  
-           PSAFE=no
  10
+PSAFE=no
11 11
 
12 12
 cat << EOF
13 13
 MPlayer is a movie and animation player based on the 0.90pre5 version of

0 notes on commit f9d0735

Please sign in to comment.
Something went wrong with that request. Please try again.