Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Commits on Apr 18, 2012
  1. ruby: security update to 1.8.7-p358

    Zbigniew Luszpinski authored Jean-Michel Bruenn committed
Commits on Jan 27, 2012
  1. ruby: security update 1.8.7-p357

    Zbigniew Luszpinski authored
Commits on Nov 28, 2011
  1. ruby: Adding a patch to fix this problem;

    Dennis `stumbles` Veatch authored
    http://stackoverflow.com/questions/6134456/error-while-installing-ruby-1-8-7-on-fedora-15
    https://gist.github.com/1083163
    
    Not sure if it due to the glibc or binutils bump but its the same problem I had and this
    fixed it.
Commits on Jul 6, 2011
  1. ruby: updated to 1.8.7-p352

    Zbigniew Luszpinski authored
Commits on May 20, 2011
  1. Revert "ruby: Version bump and adjusting the BUILD."

    Dennis `stumbles` Veatch authored
    This reverts commit 1229935.
    
    Some one shoot me for not fully testing this. A lunar fix should be
    done at some point.
Commits on May 9, 2011
  1. ruby: Version bump and adjusting the BUILD.

    Dennis `stumbles` Veatch authored
Commits on Feb 27, 2011
  1. ruby: updated to 1.8.7-p334

    Zbigniew Luszpinski authored
Commits on Jan 23, 2011
  1. moonbase: replace old-style OPTS usage

    Paul Bredbury authored
    Done using:
    
    find -name BUILD | xargs grep 'OPTS="\$' | cut -d: -f1 > list
    cat list | xargs sed -i -e 's:OPTS="\$OPTS :OPTS+=" :'
Commits on Dec 31, 2010
  1. ruby: updated to 1.8.7-p330

    Zbigniew Luszpinski authored
Commits on Aug 23, 2010
  1. ruby: updated to 1.8.7-p302

    Zbigniew Luszpinski authored
    Ruby 1.8.7-p302 has been released([ruby-talk:367769]).
    This is a security fix for CVE-2010-0541.
    See the vulnerability report for more details.
Commits on Jun 23, 2010
  1. ruby: updated to 1.8.7-p299

    Zbigniew Luszpinski authored
Commits on Apr 12, 2010
  1. @Florin65

    ruby: fix the patch url.

    Florin65 authored
  2. @Florin65
Commits on Jan 30, 2010
  1. ruby: Security update to 1.8.7-p249

    Zbigniew Luszpinski authored
    WEBrick has an Escape Sequence Injection vulnerability
    A vulnerability was found on WEBrick, a part of Ruby's standard library.
    WEBrick lets attackers to inject malicious escape sequences to its logs,
    making it possible for dangerous control characters to be executed on a victim's terminal emulator.
    
    Affected versions
        * Ruby 1.8.6 patchlevel 383 and all prior versions
        * Ruby 1.8.7 patchlevel 248 and all prior versions
        * Development versions of Ruby 1.8 (1.8.8dev)
        * Ruby 1.9.1 patchlevel 376 and all prior versions
        * Development versions of Ruby 1.9 (1.9.2dev)
Commits on Dec 25, 2009
  1. ruby: updated to patchlevel p248

    Zbigniew Luszpinski authored
Commits on Nov 24, 2009
  1. @dagbrown

    ruby: Patchlevel bump

    dagbrown authored
    Also, the Ruby maintainers removed previous patch releases, rendering
    the current module 404-compliant.  Whoops.
Commits on Jul 31, 2009
  1. ruby: rolling back to 1.8.7-p160.

    Dave Brown authored
    Ruby 1.9.x is the *BETA* version.  It is not, and will never be, the
    stable version of Ruby.  The next stable major version of Ruby will be
    version 2.0.
Commits on Jul 28, 2009
  1. ruby: updated to 1.9.1-p243

    Zbigniew Luszpinski authored
Commits on May 2, 2009
  1. @Florin65

    ruby: version bumped to 1.8.7-p160.

    Florin65 authored
    Security release.
Commits on Dec 15, 2008
  1. ruby: Version bump to 1.8.7-p72.

    Terry Chan authored
    Our resident ruby guru (dagbrown) said it was okay to finally bump Ruby to the
    1.8.7 level now.
Commits on Jun 21, 2008
  1. @dagbrown

    ruby: Security update: 1.8.6pl114 -> 1.8.6pl230

    dagbrown authored Dave Brown committed
    See:
      http://www.ruby-lang.org/en/news/2008/06/20/arbitrary-code-execution-vulnerabilities/
    
    for details, and
    
        http://www.zedshaw.com/rants/the_big_ruby_vulnerabilities.html
    
    for a guy with a huge ego talking about them (and of course about how
    awesome he is) in detail.
Commits on Jun 18, 2008
  1. @dagbrown

    ruby: rolling back to 1.8.6

    dagbrown authored Dave Brown committed
    Ruby 1.8.7 breaks a number of things (including things like XMLRPC which
    honestly shouldn't even be changing), and until those are resolved, it
    should stay at 1.8.6.
Commits on Jun 10, 2008
  1. @Florin65

    ruby: version bumped to 1.8.7-p17.

    Florin65 authored
    Bugfixes release.
Commits on Jun 1, 2008
  1. @Florin65

    ruby: version bumped to 1.8.7.

    Florin65 authored
    The new version of Ruby includes many bug fixes, lots of
    feature enhancements backported from 1.9 and some performance
    improvements since 1.8.6 while maintaining stability and
    backward compatibility with the previous release to a high
    degree.
Commits on Mar 4, 2008
  1. @Florin65

    ruby: version bump to 1.8.6-p114.

    Florin65 authored
    Bugfixes and enhacements.
Commits on Oct 4, 2007
  1. bump the version from 1.8.6-p110 to 1.8.6-p111. bugfixes.

    florin authored
    git-svn-id: svn+ssh://foo-projects.org/var/svn/lunar/moonbase/trunk@26083 fe636330-a7f5-0310-8408-fdd8893149bb
Commits on Sep 23, 2007
  1. bump the version from 1.8.6-p36 to 1.8.6-p110. bugfixes release.

    florin authored
    git-svn-id: svn+ssh://foo-projects.org/var/svn/lunar/moonbase/trunk@25954 fe636330-a7f5-0310-8408-fdd8893149bb
Commits on Aug 25, 2007
  1. Reverting dveatch commit which downgraded ruby

    ratler authored
    git-svn-id: svn+ssh://foo-projects.org/var/svn/lunar/moonbase/trunk@25608 fe636330-a7f5-0310-8408-fdd8893149bb
Commits on Aug 23, 2007
  1. Version bump. Thar be some gems in thar.

    stumbles authored
    git-svn-id: svn+ssh://foo-projects.org/var/svn/lunar/moonbase/trunk@25597 fe636330-a7f5-0310-8408-fdd8893149bb
Commits on Aug 7, 2007
  1. Removing stinking tabs. Don't use tabs in moonbase!!!

    tchan authored
    git-svn-id: svn+ssh://foo-projects.org/var/svn/lunar/moonbase/trunk@25386 fe636330-a7f5-0310-8408-fdd8893149bb
Commits on Jul 26, 2007
  1. Graphviz insists on looking for a static ruby.

    stumbles authored
    git-svn-id: svn+ssh://foo-projects.org/var/svn/lunar/moonbase/trunk@25287 fe636330-a7f5-0310-8408-fdd8893149bb
Commits on Jun 9, 2007
  1. bump the version from 1.8.6 to 1.8.6-p36. bugfixes release.

    florin authored
    git-svn-id: svn+ssh://foo-projects.org/var/svn/lunar/moonbase/trunk@24759 fe636330-a7f5-0310-8408-fdd8893149bb
Commits on Mar 13, 2007
  1. bump the version from 1.8.5-p12 to 1.8.6. bugfixes, improvements and …

    florin authored
    …optimizations.
    
    git-svn-id: svn+ssh://tchan@foo-projects.org/var/svn/lunar/moonbase/trunk@23619 fe636330-a7f5-0310-8408-fdd8893149bb
Commits on Dec 26, 2006
  1. bump the version from 1.8.5-p11 to 1.8.5-p12. bugfixes.

    florin authored
    git-svn-id: svn+ssh://tchan@foo-projects.org/var/svn/lunar/moonbase/trunk@22771 fe636330-a7f5-0310-8408-fdd8893149bb
Commits on Dec 20, 2006
  1. bump the version from 1.8.5-p2 to 1.8.5-p11. bugfixes, including secu…

    florin authored
    …rity related ones.
    
    git-svn-id: svn+ssh://tchan@foo-projects.org/var/svn/lunar/moonbase/trunk@22682 fe636330-a7f5-0310-8408-fdd8893149bb
Something went wrong with that request. Please try again.