cabal install requires cpphs downgrade #12

Merged
merged 1 commit into from Mar 8, 2013

Conversation

Projects
None yet
2 participants
@brow
Contributor

brow commented Mar 4, 2013

Installing hothasktags under the latest haskell-platform requires a potentially destructive downgrade:

$ cabal install hothasktags
Resolving dependencies...
In order, the following would be installed:
cpphs-1.14 (new version)
haskell-src-exts-1.13.5 (reinstall) changes: cpphs-1.16 -> 1.14
hothasktags-0.3.0 (new package)
cabal: The following packages are likely to be broken by the reinstalls:
hoogle-4.2.15
hlint-1.8.43
HTF-0.10.0.7
Use --force-reinstalls if you want to install anyway.

I incremented hothasktag's upper bound on cpphs's version to avoid this.

@brow

This comment has been minimized.

Show comment Hide comment
@brow

brow Mar 4, 2013

Owner

This commit also removes some trailing whitespace.

Owner

brow commented on 7ea7797 Mar 4, 2013

This commit also removes some trailing whitespace.

luqui added a commit that referenced this pull request Mar 8, 2013

Merge pull request #12 from brow/cpphs-dep
cabal install requires cpphs downgrade

@luqui luqui merged commit 73ec9fd into luqui:master Mar 8, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment