Skip to content
This repository

Setting up dev environment

Prerequisites

  • mongoDB
  • Python 2.5+ - should be already installed on *nix & OSX
  • virtualenv
    • Ubuntu users try sudo apt-get install python-virtualenv
    • OSX comes with easy_install but may require xcode installed. Alternatively use brew / macports

Method

  • Check out a copy of the code
git clone https://lwc@github.com/lwc/triage.git
  • Create a virtual environment for the python dependencies
cd triage
virtualenv --no-site-packages env
source ./env/bin/activate
  • Install development dependencies (neat huh?)
python setup.py develop
  • Confirm everything is working
paster serve development.ini
Something went wrong with that request. Please try again.