Permalink
Commits on Sep 20, 2017
Commits on Sep 19, 2017
Commits on Jun 29, 2017
  1. [TASK] Remove workaround for Ruby 2.3.3 (#77)

    oliverklee committed with lwe Jun 29, 2017
    As we are now using Ruby 2.3.4 in Travis, the workaround is no longer needed
    for the CI. This should speed up the builds a bit.
Commits on May 3, 2017
Commits on Apr 9, 2017
Commits on Feb 24, 2017
  1. [CLEANUP] Fix more Rubocop warnings (#71)

    oliverklee committed with lwe Feb 24, 2017
    - remove trivial accessors
    - remove unnecessary self
Commits on Feb 15, 2017
Commits on Jan 31, 2017
  1. [TASK] Cleanup and improve the RuboCop configuration (#67)

    oliverklee committed with lwe Jan 31, 2017
    - call RuboCop with the --rails option to add Rails-specific cops
    - put the open RobuCops to-dos in .rubocop_todo.yml and include it
      from the main RuboCop configuration (as recommended by RuboCop)
    - use Rails-style indentation style settings
    - set the RuboCop target version to 2.0 (the lowest Ruby version
      supported by this gem)
Commits on Jan 30, 2017
Commits on Jan 29, 2017
  1. 🎨 remove appraisals dependency (use Gemfiles) (#41)

    lwe committed with oliverklee Jan 29, 2017
    Appraisails basically just creates additional gemfiles in the
    gemfiles/ directory. These should be simple enough to manage without
    an additional gem.
    
    - remove appraisals dev dependency
    - reduce number gemfiles:
      > Gemfile (latest rails)
      > gemfiles/Gemfile.rails-4-2
      > gemfiles/Gemfile.rails-5-0
    - configure travis to exclude ruby <2.3 tests for Rails 5
  2. [TASK] Add a CHANGELOG.md (#59)

    oliverklee committed with lwe Jan 29, 2017
    This file lists all changes that affect the way the Gem works or how it
    can be used, but not non-functional cleanup.
    
    [ci skip]
    
    Fixes #50
Commits on Jan 26, 2017
  1. [TASK] Link the code of conduct file (#58)

    oliverklee committed with lwe Jan 26, 2017
    - link it from the README.md
    - add it to the list of files in the gemspec
    
    [ci skip]
  2. [CLEANUP] Delete obselete init.rb file (#61)

    lwe committed with oliverklee Jan 26, 2017
    The init.rb file dates back to Rails 2 plugins, if I recall correctly.
    
    Fixes #57
  3. [TASK] Add RuboCop checking to the CI (#52)

    oliverklee committed with lwe Jan 26, 2017
    This commit only add the checks. It does not fix the warnings yet,
    but whitelists them instead so they can be fixed in separate PRs.
    
    Fixes #14
Commits on Jan 24, 2017
  1. [TASK] Document that the project uses semantic versioning (#54)

    oliverklee committed with lwe Jan 24, 2017
    [ci skip]
    
    Fixes #44
  2. [TASK] Add a CODE_OF_CONDUCT.md (#51)

    oliverklee committed with lwe Jan 24, 2017
    Fixes #37
    
    [ci skip]
  3. [CLEANUP] Polish the README (#55)

    oliverklee committed with lwe Jan 24, 2017
    - list Rails 4.2 and 5 instead of 3
    - add a missing comma
    
    [ci skip]
Commits on Jan 20, 2017
Commits on Jan 19, 2017
  1. [CLEANUP] Stop requiring version from the main class (#47)

    oliverklee committed with lwe Jan 19, 2017
    It suffices to require the file from the gemspec file.
    
    Fixes #43
Commits on Nov 22, 2016
Commits on Jul 2, 2016
  1. [TASK] Add Rails 5.0 to the build matrix (#38)

    oliverklee committed with lwe Jul 2, 2016
    Also update Ruby 2.2 to 2.2.5 and 2.3.0 to 2.3.1 for the Travis builds.
  2. [TASK] Drop support for Rails 3.2 and 4.0 (#39)

    oliverklee committed with lwe Jul 2, 2016
    There will not be any updates anymore for Rails 3.2, 4.0 or 4.1
    according to http://guides.rubyonrails.org/maintenance_policy.html .
    
    Fixes #25
Commits on Feb 2, 2016
  1. Merge pull request #36 from lwe/task/ruby-2.3

    lwe committed Feb 2, 2016
    [TASK] Add Ruby 2.3.0 to the build matrix
  2. [TASK] Add Ruby 2.3.0 to the build matrix

    oliverklee committed Feb 2, 2016
Commits on Feb 25, 2015
  1. Merge pull request #33 from lwe/task/ruby-version

    lwe committed Feb 25, 2015
    [TASK] Drop support for Ruby 1.9.x
Commits on Feb 24, 2015
  1. [TASK] Drop support for Ruby 1.9.x

    oliverklee committed Feb 24, 2015
    Ruby 1.9.3 was end-of-lifed on 2015-02-23.
    
    Closes #24