Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Very slow speed with rtl8812ae (DWA-582) #397

Open
blastrock opened this Issue Sep 10, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@blastrock
Copy link

blastrock commented Sep 10, 2018

Hi

I have a very slow speed with my wifi card, as a lot of other people seem to have. I have around 100KB/s on 2.4GHz and 500KB/s on 5GHz, measured with iperf3.

The network I connect to is:

          Cell 03 - Address: ...
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=62/70  Signal level=-48 dBm  
                    Encryption key:on
                    ESSID:"..."
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000000006f709a37
                    Extra: Last beacon: 96ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK

The interface in iwconfig is:

wlp7s0    IEEE 802.11  ESSID:"..."  
          Mode:Managed  Frequency:2.412 GHz  Access Point: ...   
          Bit Rate=144.4 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=66/70  Signal level=-44 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:12   Missed beacon:0

And my card, as shown by lspci:

07:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8812AE 802.11ac PCIe Wireless Network Adapter (rev 01)
        Subsystem: D-Link System Inc RTL8812AE 802.11ac PCIe Wireless Network Adapter
        Flags: bus master, fast devsel, latency 0, IRQ 32
        I/O ports at 8e00 [size=256]
        Memory at fd6fc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number ...
        Capabilities: [150] Latency Tolerance Reporting
        Capabilities: [158] L1 PM Substates
        Kernel driver in use: rtl8821ae
        Kernel modules: rtl8821ae

I have tested a lot of different things without success:

  • linux 4.4 with official driver and firmware
  • linux 4.4 with this repo's master branch
  • linux 4.15 with official driver and firmware which gives me:
[66946.221386] rtl8821ae: Using firmware rtlwifi/rtl8812aefw.bin
[66946.221388] rtl8821ae: Using firmware rtlwifi/rtl8812aefw_wowlan.bin
[66946.225201] ieee80211 phy3: Selected rate control algorithm 'rtl_rc'
[66946.225459] rtlwifi: rtlwifi: wireless switch is on
[66946.225553] rtl8821ae 0000:07:00.0: Direct firmware load for rtlwifi/rtl8812aefw.bin failed with error -2
[66946.225596] rtlwifi: Loading alternative firmware rtlwifi/rtl8821aefw.bin
[66946.225613] rtl8821ae 0000:07:00.0: Direct firmware load for rtlwifi/rtl8812aefw_wowlan.bin failed with error -2
[66946.225629] rtlwifi: Loading alternative firmware rtlwifi/rtl8821aefw.bin
[66946.228283] rtl8821ae 0000:07:00.0 wlp7s0: renamed from wlan1
[66946.338245] rtl8821ae: Polling FW ready fail!! REG_MCUFWDL:0x80070706 .
  • linux 4.15 with official driver and this repo's master branch's firmware:
[67640.905067] rtl8821ae: Using firmware rtlwifi/rtl8812aefw.bin
[67640.905070] rtl8821ae: Using firmware rtlwifi/rtl8812aefw_wowlan.bin
[67640.906502] ieee80211 phy10: Selected rate control algorithm 'rtl_rc'
[67640.909308] rtlwifi: rtlwifi: wireless switch is on
[67640.909786] rtl8821ae 0000:07:00.0 wlp7s0: renamed from wlan1

This occurs whether the card is in AP mode or Managed. I am doing all my tests in Managed mode on a WPA2 network for now, to rule out hostapd.

I have also tried setting int_clear=0 fwlps=0 ips=0. The rtl8821ae driver doesn't have a ant_sel option, so nothing to try there.

I don't know what else to try. Please tell me if I can provide more information, try other things, or retry things that I have already tried if they seem fishy to you.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.