Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Setting Up a Linux Development Environment

lylejohnson edited this page · 4 revisions

If you would like to be able to build FXRuby from source on Linux, and perhaps even contribute patches back to the project, you’re going to need to set up a development environment. This page describes how to set up an FXRuby development environment on Ubuntu Linux 9.04.

Set Up the Build Environment

For starters, you need to follow the instructions on the Setting Up a Linux Build Environment page. So go do that, then come back here when you’re done.

Download, Build and Install SWIG

We use a very, very old version of SWIG to generate the wrapper code for FXRuby. Actually, this is only true for the “1.6” branch of FXRuby, but that’s the one that you’ll probably be dealing with. You can download the source tarball for SWIG version 1.3.22 from the SWIG downloads page and then build and install it.

tar xzf swig-1.3.22.tar.gz
cd SWIG-1.3.22
./configure
make
make install

Install Git

Perhaps this goes without saying, but if you want to be able to check out the FXRuby code, you’re going to need to have Git installed. Type the following command to install Git:

sudo aptitude install git-core

Install Rake, Hoe and rake-compiler

Many of the tasks related to FXRuby development are encoded in its Rakefile, and that Rakefile depends on tasks from Hoe and rake-compiler, so you need to install those gems:

sudo gem install rake hoe rake-compiler

Check out the Code

If you think you’ll want to make changes to the FXRuby code, and possibly submit patches back to the project, you’ll want to fork the project and then check out your forked version. Otherwise, you can just do a regular git clone of the FXRuby repository. In either case, refer to the GitHub guides for information about these things are done.

Something went wrong with that request. Please try again.