Permalink
Browse files

Lower required python version to 3.1

migen is confirmed to work fine with python 3.1, so lower the required version
from 3.2 to 3.1.

Signed-off-by: Lars-Peter Clausen <lars@metafoo.de>
  • Loading branch information...
1 parent 3143608 commit 9f05e7235d0d9aab0385e4610fe3405bc0af9749 @larsclausen larsclausen committed Jan 31, 2012
Showing with 2 additions and 2 deletions.
  1. +2 −2 setup.py
View
@@ -1,4 +1,4 @@
-#!/usr/bin/env python3.2
+#!/usr/bin/env python3
# vim: noexpandtab:tabstop=8:softtabstop=8
""" Migen's distutils distribution and installation script. """
@@ -8,7 +8,7 @@
here = os.path.abspath(os.path.dirname(__file__))
README = open(os.path.join(here, "README")).read()
-required_version = (3, 2)
+required_version = (3, 1)
if sys.version_info < required_version:
raise SystemExit("migen requires python {0} or greater".format(
".".join(map(str, required_version))))

0 comments on commit 9f05e72

Please sign in to comment.