Error on mvn package -- Symbol's function definition is void: eieio-defclass-autoload #58

Closed
psylinse opened this Issue Jan 26, 2011 · 2 comments

Comments

Projects
None yet
3 participants
@psylinse

Hey there-

I am trying to build malabar on Ubuntu 10.10 using GNU Emacs 23.2 with built in CEDET. I get an error upon emacs trying to execute load-all.el. It seems like an issue with semantic, but I'm not sure.

Here is the full output:

[INFO] [exec:exec {execution: run-elisp-tests}]
[INFO] Loading /home/psylinse/malabar-mode/src/test/lisp/malabar-util.elk...
[INFO] [exec:exec {execution: run-loadability-test}]
[INFO] "/usr/share/emacs/23.2/site-lisp/cedet-common/" added to `load-path'
[INFO] Setting up cedet...
[INFO] Setting up cedet...done
[INFO] Setting up cogre...
[INFO] Setting up cogre...done
[INFO] Setting up ede...
[INFO] Loading `eieio': old-style backquotes detected!
[INFO] Loading vc-git...
[INFO] Setting up ede...done
[INFO] Setting up eieio...
[INFO] Setting up eieio...done
[INFO] Setting up semantic...
[INFO] Setting up semantic...done
[INFO] Setting up speedbar...
[INFO] Setting up speedbar...done
[INFO] Setting up cedet-contrib...
[INFO] Setting up cedet-contrib...done
[INFO] Symbol's function definition is void: eieio-defclass-autoload
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Result of /bin/sh -c cd /home/psylinse/malabar-mode && emacs -Q --batch -l src/test/lisp/load-all.el execution is: '255'.

Any ideas? Thanks!

@jeffbowman

This comment has been minimized.

Show comment Hide comment
@jeffbowman

jeffbowman Apr 6, 2011

I ran into this as well. The version of cedet-common packaged with ubuntu 10.10 is 1.0pre4 and eieio 1.0. I had to get rid of cedet from the package manager and install from the cedet website. I used the released tar file which gave me cedet 1.0 and eieio 1.3. This worked for me.

I ran into this as well. The version of cedet-common packaged with ubuntu 10.10 is 1.0pre4 and eieio 1.0. I had to get rid of cedet from the package manager and install from the cedet website. I used the released tar file which gave me cedet 1.0 and eieio 1.3. This worked for me.

@m0smith

This comment has been minimized.

Show comment Hide comment
@m0smith

m0smith Jan 16, 2015

Owner

The cedet we are using does not appear to have this issue.

Owner

m0smith commented Jan 16, 2015

The cedet we are using does not appear to have this issue.

@m0smith m0smith closed this Jan 16, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment