Permalink
Browse files

travis configuration

  • Loading branch information...
1 parent 234f5af commit 5fdda88490058f6a90be366943adf6a85f5bcea1 @ghempton ghempton committed Dec 23, 2012
Showing with 12 additions and 3 deletions.
  1. +4 −0 .travis.yml
  2. +5 −3 Appraisals
  3. +1 −0 ember-rails.gemspec
  4. +1 −0 gemfiles/rails3.gemfile.lock
  5. +1 −0 gemfiles/rails4.gemfile.lock
View
@@ -1,3 +1,7 @@
rvm:
- 1.8.7
- 1.9.3
+before_install:
+ - gem install bundler --version '>= 1.2.2'
+before_script: "bundle exec rake appraisal:install"
+script: "bundle exec rake appraisal test"
View
@@ -2,7 +2,9 @@ appraise "rails3" do
gem 'rails', '~> 3.1'
end
-appraise "rails4" do
- gem 'rails', :git => 'https://github.com/rails/rails.git'
- gem 'activerecord-deprecated_finders', :git => 'https://github.com/rails/activerecord-deprecated_finders.git'
+unless RUBY_VERSION == "1.8.7"
+ appraise "rails4" do
+ gem 'rails', :git => 'https://github.com/rails/rails.git'
+ gem 'activerecord-deprecated_finders', :git => 'https://github.com/rails/activerecord-deprecated_finders.git'
+ end
end
View
@@ -16,6 +16,7 @@ Gem::Specification.new do |s|
s.add_dependency "active_model_serializers"
s.add_dependency "barber"
+ s.add_development_dependency "bundler", [">= 1.2.2"]
s.add_development_dependency "appraisal"
s.files = %w(README.md LICENSE) + Dir["lib/**/*", "vendor/**/*"]
@@ -102,5 +102,6 @@ PLATFORMS
DEPENDENCIES
appraisal
+ bundler (>= 1.2.2)
ember-rails!
rails (~> 3.1)
@@ -112,5 +112,6 @@ PLATFORMS
DEPENDENCIES
activerecord-deprecated_finders!
appraisal
+ bundler (>= 1.2.2)
ember-rails!
rails!

0 comments on commit 5fdda88

Please sign in to comment.