Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Thin 1.4.1 can not start #115

Closed
smoothdvd opened this issue Jul 5, 2012 · 17 comments

Comments

Projects
None yet
@smoothdvd
Copy link

commented Jul 5, 2012

I just upgrade to 1.4.1 and met this error:

/usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/lib/thin/backends/tcp_server.rb:16:in `connect': cannot load such file -- thin/connection (LoadError)
    from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/lib/thin/backends/base.rb:55:in `block in start'
    from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/eventmachine-0.12.10/lib/eventmachine.rb:256:in `call'
    from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/eventmachine-0.12.10/lib/eventmachine.rb:256:in `run_machine'
    from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/eventmachine-0.12.10/lib/eventmachine.rb:256:in `run'
    from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/lib/thin/backends/base.rb:63:in `start'
    from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/lib/thin/server.rb:159:in `start'
    from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/lib/thin/controllers/controller.rb:86:in `start'
    from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/lib/thin/runner.rb:185:in `run_command'
    from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/lib/thin/runner.rb:151:in `run!'
    from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/bin/thin:6:in `<top (required)>'
    from /usr/local/rvm/gems/ruby-1.9.3-p194/bin/thin:19:in `load'
    from /usr/local/rvm/gems/ruby-1.9.3-p194/bin/thin:19:in `<main>'
    from /usr/local/rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
    from /usr/local/rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>'
@jiripospisil

This comment has been minimized.

Copy link

commented Jul 5, 2012

Getting the same error (thin start, both 1.4.1 and 1.4.0). Note that it works when used with a rails app (rails s thin).

@macournoyer

This comment has been minimized.

Copy link
Owner

commented Jul 5, 2012

How do you start the server?

On 2012-07-05, at 6:44 AM, smoothdvdreply@reply.github.com wrote:

I just upgrade to 1.4.1 and met this error:

/usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/lib/thin/backends/tcp_server.rb:16:in `connect': cannot load such file -- thin/connection (LoadError)
   from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/lib/thin/backends/base.rb:55:in `block in start'
   from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/eventmachine-0.12.10/lib/eventmachine.rb:256:in `call'
   from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/eventmachine-0.12.10/lib/eventmachine.rb:256:in `run_machine'
   from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/eventmachine-0.12.10/lib/eventmachine.rb:256:in `run'
   from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/lib/thin/backends/base.rb:63:in `start'
   from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/lib/thin/server.rb:159:in `start'
   from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/lib/thin/controllers/controller.rb:86:in `start'
   from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/lib/thin/runner.rb:185:in `run_command'
   from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/lib/thin/runner.rb:151:in `run!'
   from /usr/local/rvm/gems/ruby-1.9.3-p194/gems/thin-1.4.1/bin/thin:6:in `<top (required)>'
   from /usr/local/rvm/gems/ruby-1.9.3-p194/bin/thin:19:in `load'
   from /usr/local/rvm/gems/ruby-1.9.3-p194/bin/thin:19:in `<main>'
   from /usr/local/rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
   from /usr/local/rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>'

Reply to this email directly or view it on GitHub:
#115

@smoothdvd

This comment has been minimized.

Copy link
Author

commented Jul 5, 2012

Simply use "thin start" and "thin -s3 -d -p5000 start"

@macournoyer

This comment has been minimized.

Copy link
Owner

commented Jul 5, 2012

Did you add thin to your Gemfile?

@macournoyer

This comment has been minimized.

Copy link
Owner

commented Jul 5, 2012

Weird that it worked before. Which version were you using before?

@smoothdvd

This comment has been minimized.

Copy link
Author

commented Jul 5, 2012

I add thin to Gemfie, and it works again! Thank you!

@macournoyer macournoyer closed this Jul 5, 2012

@venky-D

This comment has been minimized.

Copy link

commented Dec 28, 2012

Before #thin s
Just add thin to Gemfie, like

gem 'thin'

and it works! Thank you!

@fotanus

This comment has been minimized.

Copy link

commented May 23, 2013

I suggest adding this to the homepage that doesn't cover Gemfile. If it was not necessary it is ok not cover, but since it is, better update.

@bendilley

This comment has been minimized.

Copy link

commented Jun 4, 2013

+1 for the comment by @fotanus - google brought me here after I failed to start my rails app with Thin, but I'd started on the usage page, so adding the extra step there would really help.

cd to/your/rails/app
echo 'gem "thin"' >> Gemfile
thin start
@macournoyer

This comment has been minimized.

Copy link
Owner

commented Jul 12, 2013

Updated the usage page. Sorry for the delays and thx for suggesting.

@christiangenco

This comment has been minimized.

Copy link

commented Oct 7, 2013

+1 for adding gem "thin" to the Gemfile.

@vforge

This comment has been minimized.

Copy link

commented Mar 27, 2015

👍

@ghost

This comment has been minimized.

Copy link

commented May 13, 2015

adding gem "thin" to the Gemfile worked for me as well. Thanks

@mooreniemi

This comment has been minimized.

Copy link

commented Jul 30, 2015

👍

3 similar comments
@sobolevn

This comment has been minimized.

Copy link

commented Aug 23, 2015

👍

@danhsh

This comment has been minimized.

Copy link

commented Jan 28, 2016

👍

@23ranjan

This comment has been minimized.

Copy link

commented Oct 19, 2016

👍

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.