Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
68 lines (49 sloc) 2.44 KB
# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:ft=tcl:et:sw=4:ts=4:sts=4
PortSystem 1.0
PortGroup cmake 1.0
PortGroup github 1.0
github.setup dl1ksv gr-fcdproplus 0006c36320cd7a3bc786dd6f186c94809bf445cc
version 20180828
checksums rmd160 f71fa01127e21a79b662dbc2a22bc6e1b4030e69 \
sha256 187744ef7154008a2c6f0c636e2963674ded75d77b580b77626b7c47c285fb5f \
size 132229
categories science comms
maintainers {michaelld @michaelld} openmaintainer
description Implements a funcube dongle pro+ source in GNU Radio.
long_description ${description}
license GPL-3
platforms darwin
depends_build-append port:pkgconfig
depends_lib-append port:boost \
port:doxygen \
path:lib/libusb-1.0.dylib:libusb \
port:swig-python
# allow gr-fcdproplus to work with both gnuradio and gnuradio-devel ...
depends_lib-append path:lib/libgnuradio-runtime.dylib:gnuradio
# ... but not with gnuradio-next
pre-fetch {
if {![catch {set installed [lindex [registry_active gnuradio-next] 0]}]} {
# gnuradio-next is installed; this version of gr-fcdproplus does not work with gnuradio-next
ui_msg "\nError: ${name} requires the gnuradio or gnuradio-devel port, and will not work with the gnuradio-next port. deactivate gnuradio-next, and then install or activate gnuradio or gnuradio-devel.\n"
return -code error "Invalid port dependency: gnuradio-next"
}
}
# fix search path for GNU Radio CMake modules
pre-patch {
reinplace "/HINTS/s@/lib/@/share/@" \
${worksrcpath}/cmake/Modules/FindGnuradioModules.cmake
}
# do VPATH (out of source tree) build
cmake.out_of_source yes
# remove top-level library path, such that internal libraries are used
# instead of any already-installed ones.
configure.ldflags-delete -L${prefix}/lib
# specify the Python dependencies
depends_lib-append \
port:python27
# specify the Python version to use
configure.args-append \
-DPYTHON_EXECUTABLE=${frameworks_dir}/Python.framework/Versions/2.7/bin/python2.7 \
-DPYTHON_INCLUDE_DIR=${frameworks_dir}/Python.framework/Versions/2.7/Headers \
-DPYTHON_LIBRARY=${frameworks_dir}/Python.framework/Versions/2.7/Python \
-DGR_PYTHON_DIR=${frameworks_dir}/Python.framework/Versions/2.7/lib/python2.7/site-packages
You can’t perform that action at this time.