Skip to content
Permalink
Browse files

clang-3.7: disable build on Mojave and newer

  • Loading branch information
kencu committed Oct 3, 2018
1 parent 2aedc5e commit 150fe961252b542f2581ade793f7356a36e7f68f
Showing with 11 additions and 0 deletions.
  1. +11 −0 lang/llvm-3.7/Portfile
@@ -436,6 +436,17 @@ if {${subport} eq "llvm-${llvm_version}"} {
file delete -force ${destroot}${sub_prefix}/libexec/clang-format/CMakeLists.txt
file delete -force ${destroot}${sub_prefix}/libexec/clang-format/ClangFormat.cpp
}

if {${os.platform} eq "darwin" && ${os.major} > 17} {
depends_build
depends_lib
depends_run
archive_sites
pre-fetch {
ui_error "${subport} is not supported on macOS Mojave or newer."
return -code error {unsupported platform}
}
}
}

livecheck.type none

0 comments on commit 150fe96

Please sign in to comment.
You can’t perform that action at this time.