Skip to content
Permalink
Browse files

opencv: allow build on 10.6.8

builds on SnowLeopard against the Lion SDK.
  • Loading branch information
kencu committed Jun 26, 2020
1 parent 1ea9245 commit 7abf2b88cb226b5ce57b6846edbd03fca47c4bd0
Showing with 14 additions and 0 deletions.
  1. +14 −0 graphics/opencv/Portfile
@@ -37,6 +37,20 @@ checksums ${distname}${extract.suffix} \
sha256 1ed6f5b02a7baf14daca04817566e7c98ec668cec381e0edf534fa49f10f58a2 \
size 87430332

platform macosx {
if {${os.major} <= 10} {
# Build requires at least 10.7.3 SDK, even when targeting 10.6
set lion_sdkpath ${developer_dir}/SDKs/MacOSX10.7.sdk
if {[file exists $lion_sdkpath]} {
configure.sdkroot $lion_sdkpath
} else {
pre-fetch {
error "Building $name @${version} on Mac OS X 10.6 requires the MacOSX10.7.sdk to be present in ${developer_dir}/SDKs/"
}
}
}
}

worksrcdir opencv-${version}

conflicts opencv4

0 comments on commit 7abf2b8

Please sign in to comment.
You can’t perform that action at this time.