Skip to content
Permalink
Browse files

wine*: Prevent installation on Mojave and later

See: https://trac.macports.org/ticket/56991
See: https://lists.macports.org/pipermail/macports-users/2018-September/045704.html

Also update similar blocks for big-endian systems and for Tiger to
clear out the dependencies, archives_sites, distfiles.
  • Loading branch information...
ryandesign committed Oct 2, 2018
1 parent 0e667c6 commit 8331367de9a70be2cd942635fc262c50163c52c4
Showing with 87 additions and 24 deletions.
  1. +29 −8 x11/wine-crossover/Portfile
  2. +29 −8 x11/wine-devel/Portfile
  3. +29 −8 x11/wine/Portfile
@@ -212,7 +212,9 @@ variant x11 {
--x-lib=${prefix}/lib
}

default_variants +x11
if {${os.platform} ne "darwin" || (${os.major} >= 9 && ${os.major} <= 17)} {
default_variants +x11
}

configure.universal_args

@@ -294,18 +296,37 @@ platform darwin {

and then set "RetinaMode" to "y". You may also want to adjust your\
DPI under the Graphics tab in winecfg.}

if {${os.major} < 9} {
archive_sites
distfiles
depends_build
depends_lib
pre-fetch {
ui_error "${name} @${version} requires Mac OS X 10.5 or later."
return -code error "incompatible Mac OS X version"
}
} elseif {${os.major} > 17} {
archive_sites
distfiles
depends_build
depends_lib
pre-fetch {
ui_error "${name} cannot be built on macOS 10.14 or later."
return -code error "incompatible macOS version"
}
}
}

pre-fetch {
if {${os.endian} eq "big"} {
if {${os.endian} eq "big"} {
archive_sites
distfiles
depends_build
depends_lib
pre-fetch {
ui_error "${name} can only be used on an Intel Mac or other computer with a little-endian processor."
return -code error "incompatible processor"
}

if {${os.platform} eq "darwin" && ${os.major} < 9} {
ui_error "${name} ${version} requires OS X 10.5 or greater."
return -code error "incompatible OS X version"
}
}

post-destroot {
@@ -207,7 +207,9 @@ variant x11 {
--x-lib=${prefix}/lib
}

default_variants +x11
if {${os.platform} ne "darwin" || (${os.major} >= 9 && ${os.major} <= 17)} {
default_variants +x11
}

configure.universal_args

@@ -303,18 +305,37 @@ platform darwin {

and then set "RetinaMode" to "y". You may also want to adjust your\
DPI under the Graphics tab in winecfg.}

if {${os.major} < 9} {
archive_sites
distfiles
depends_build
depends_lib
pre-fetch {
ui_error "${name} @${version} requires Mac OS X 10.5 or later."
return -code error "incompatible Mac OS X version"
}
} elseif {${os.major} > 17} {
archive_sites
distfiles
depends_build
depends_lib
pre-fetch {
ui_error "${name} cannot be built on macOS 10.14 or later."
return -code error "incompatible macOS version"
}
}
}

pre-fetch {
if {${os.endian} eq "big"} {
if {${os.endian} eq "big"} {
archive_sites
distfiles
depends_build
depends_lib
pre-fetch {
ui_error "${name} can only be used on an Intel Mac or other computer with a little-endian processor."
return -code error "incompatible processor"
}

if {${os.platform} eq "darwin" && ${os.major} < 9} {
ui_error "${name} ${version} requires OS X 10.5 or greater."
return -code error "incompatible OS X version"
}
}

post-destroot {
@@ -208,7 +208,9 @@ variant x11 {
--x-lib=${prefix}/lib
}

default_variants +x11
if {${os.platform} ne "darwin" || (${os.major} >= 9 && ${os.major} <= 17)} {
default_variants +x11
}

configure.universal_args

@@ -290,18 +292,37 @@ platform darwin {

and then set "RetinaMode" to "y". You may also want to adjust your\
DPI under the Graphics tab in winecfg.}

if {${os.major} < 9} {
archive_sites
distfiles
depends_build
depends_lib
pre-fetch {
ui_error "${name} @${version} requires Mac OS X 10.5 or later."
return -code error "incompatible Mac OS X version"
}
} elseif {${os.major} > 17} {
archive_sites
distfiles
depends_build
depends_lib
pre-fetch {
ui_error "${name} cannot be built on macOS 10.14 or later."
return -code error "incompatible macOS version"
}
}
}

pre-fetch {
if {${os.endian} eq "big"} {
if {${os.endian} eq "big"} {
archive_sites
distfiles
depends_build
depends_lib
pre-fetch {
ui_error "${name} can only be used on an Intel Mac or other computer with a little-endian processor."
return -code error "incompatible processor"
}

if {${os.platform} eq "darwin" && ${os.major} < 9} {
ui_error "${name} ${version} requires OS X 10.5 or greater."
return -code error "incompatible OS X version"
}
}

post-destroot {

0 comments on commit 8331367

Please sign in to comment.
You can’t perform that action at this time.