Skip to content
Permalink
Browse files

Py-numpy: require a C/C++11 compliant compiler

This setting matches SciPy and allow some older macOS to build this port.

Closes: https://trac.macports.org/ticket/60711
  • Loading branch information
michaelld committed Jun 26, 2020
1 parent 0093247 commit ab921da35f56f2b2df27e27e9d9a9db3ad954a69
Showing with 8 additions and 3 deletions.
  1. +8 −3 python/py-numpy/Portfile
@@ -6,9 +6,6 @@ PortGroup github 1.0
PortGroup compilers 1.0
PortGroup compiler_blacklist_versions 1.0

# some older Clang say they support SIMD when they don't
compiler.blacklist-append {clang < 900}

name py-numpy
categories-append math
license BSD
@@ -39,6 +36,14 @@ python.consistent_destroot yes
# https://trac.macports.org/ticket/48263
#universal_variant no

# some older Clang say they support SIMD when they don't
compiler.blacklist-append {clang < 900}

# require a C/C++11 compliant compiler, to match SciPy and allow some
# older macOS to build this port.
compiler.c_standard 2011
compiler.cxx_standard 2011

# default livecheck
github.livecheck.regex {(\d+(?:\.\d+)+)}

0 comments on commit ab921da

Please sign in to comment.
You can’t perform that action at this time.