Skip to content
Permalink
Browse files

py-jupyterlab: make compatible with recent jupyterlab_server

  • Loading branch information...
stromnov committed Mar 15, 2019
1 parent 4f4d2c1 commit ae3628b7e2656f6c6b0ee0e622dd1dd7830515f7
@@ -5,7 +5,7 @@ PortGroup python 1.0

name py-jupyterlab
version 0.35.4
revision 0
revision 1
categories-append devel
platforms darwin
license BSD
@@ -48,6 +48,9 @@ if {${name} ne ${subport}} {
depends_lib-append port:py${python.version}-futures \
port:py${python.version}-subprocess32
}
} else {
patchfiles-append 3b8d451e6f9a4c609e60cde5fbb3cc84aae79951.patch
patch.pre_args -p1
}

build.args-append --skip-npm
@@ -0,0 +1,22 @@
From 3b8d451e6f9a4c609e60cde5fbb3cc84aae79951 Mon Sep 17 00:00:00 2001
From: Afshin Darian <git@darian.af>
Date: Fri, 15 Feb 2019 16:22:14 +0000
Subject: [PATCH] Bump jupyterlab_server version.

---
setup.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/setup.py b/setup.py
index df6c8a78d5b..6a1fdc749ae 100644
--- a/setup.py
+++ b/setup.py
@@ -133,7 +133,7 @@ def run(self):

setup_args['install_requires'] = [
'notebook>=4.3.1',
- 'jupyterlab_server>=0.2.0,<0.3.0'
+ 'jupyterlab_server>=0.3.0,<0.4.0'
]

setup_args['extras_require'] = {

0 comments on commit ae3628b

Please sign in to comment.
You can’t perform that action at this time.