Skip to content
Permalink
Browse files

libetonyek: blacklist incompatible compilers

fixes build on older systems
closes: https://trac.macports.org/ticket/48183
  • Loading branch information
kencu committed May 18, 2020
1 parent b2d4ca1 commit bd915bd0735d7686fbc0048ac38f8b210eac23c6
Showing with 4 additions and 0 deletions.
  1. +4 −0 textproc/libetonyek/Portfile
@@ -1,6 +1,7 @@
# -*- coding: utf-8; mode: tcl; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- vim:fenc=utf-8:ft=tcl:et:sw=4:ts=4:sts=4

PortSystem 1.0
PortGroup compiler_blacklist_versions 1.0

name libetonyek
version 0.1.2
@@ -30,6 +31,9 @@ depends_lib port:zlib \
port:libxml2 \
port:glm

# error "GLM requires Clang 3.4 / Apple Clang 6.0 or higher"
compiler.blacklist-append {clang < 600} macports-clang-3.3

# disable some of the chattiest warnings (gives significant speed-up, about 14% for me)
configure.cflags-append -Wno-c99-extensions -Wno-variadic-macros -Wno-c++11-long-long
configure.cxxflags-append -Wno-c99-extensions -Wno-variadic-macros -Wno-c++11-long-long

0 comments on commit bd915bd

Please sign in to comment.
You can’t perform that action at this time.