Permalink
Browse files

inkscape: backport upstream poppler fixes through 0.71, rebuild

  • Loading branch information...
dbevans committed Dec 5, 2018
1 parent 5ae690c commit cdd987205b2186ae775b3aeff1e1fb2ca22c07e9
@@ -6,7 +6,7 @@ PortGroup compiler_blacklist_versions 1.0
name inkscape
conflicts inkscape-devel
version 0.92.3
revision 5
revision 6
license GPL-2 LGPL-2.1
maintainers {devans @dbevans}
categories graphics gnome
@@ -67,6 +67,9 @@ patchfiles-append 10e8ae0ff522d3a9caeed9a7f137cdfd795ba0a3.diff \
# fix for poppler 0.69
patchfiles-append patch-poppler-0.69.diff
# additional fix for poppler 0.71
patchfiles-append patch-poppler-0.71.diff
post-patch {
reinplace "s|@@MP_PERL@@|${prefix}/bin/perl${perl_version}|" ${worksrcpath}/Makefile.am
reinplace "s|\"python-interpreter\", \"python\"|\"python-interpreter\", \"python2.7\"|g" ${worksrcpath}/src/extension/implementation/script.cpp
Oops, something went wrong.

0 comments on commit cdd9872

Please sign in to comment.