Skip to content
Permalink
Browse files

ht: Specify C++98 standard

Fixes build failure with compilers that default to C++11 or newer.
  • Loading branch information
ryandesign committed Dec 2, 2019
1 parent 10da266 commit ce79d0fed1513fb5797c9b4d37abb52bcc0fe008
Showing with 6 additions and 0 deletions.
  1. +6 −0 devel/ht/Portfile
@@ -30,6 +30,12 @@ post-patch {
file attributes ${worksrcpath}/install-sh -permissions +x
}

# The next version will require C++14
# See https://github.com/sebastianbiallas/ht/commit/e52dfb86aa2c370d7d1ac2e046a4b9babc93bac9
# and https://github.com/sebastianbiallas/ht/commit/1b08f8670c3468e1b9c312650d74b037b47fc079
compiler.cxx_standard 1998
configure.cxxflags-append -std=c++98

post-destroot {
xinstall -d ${destroot}${prefix}/share/doc/${name}
xinstall -m 644 -W ${worksrcpath} COPYING README doc/ht.html \

0 comments on commit ce79d0f

Please sign in to comment.
You can’t perform that action at this time.