Permalink
Browse files

libvpx: update to version 1.8.0

ABI incompatible with previous version 1.7.0.
  • Loading branch information...
dbevans committed Feb 10, 2019
1 parent e4b5bc7 commit dd32ed809262ca219968c79aea897f2446e93331
@@ -5,7 +5,7 @@ PortGroup compiler_blacklist_versions 1.0
PortGroup muniversal 1.0

name libvpx
version 1.7.0
version 1.8.0
categories multimedia
maintainers {devans @dbevans} openmaintainer
platforms darwin
@@ -50,7 +50,8 @@ platform darwin {

patchfiles patch-build-make-configure.sh.diff \
patch-configure.diff \
patch-Makefile.diff
patch-Makefile.diff \
patch-lib.mk.diff

# clang 425.0.28 with libvpx-1.4.0:
# vp9/common/x86/vp9_subpixel_8t_intrin_avx2.c:77:16: error: assigning to '__m256i' from incompatible type 'int'
@@ -78,7 +79,6 @@ configure.args --enable-vp8 \
--enable-multithread \
--enable-runtime-cpu-detect \
--enable-experimental \
--enable-spatial-svc \
--enable-shared \
--disable-install-docs \
--disable-debug-libs \
@@ -138,7 +138,7 @@ if {![variant_isset universal]} {
# shared library uses relative path in install name
# override with absolute path
post-destroot {
set libname ${prefix}/lib/${name}.5.dylib
set libname ${prefix}/lib/${name}.6.dylib
system "install_name_tool -id ${libname} ${destroot}${libname}"
}

@@ -1,6 +1,6 @@
--- build/make/Makefile.orig 2018-02-06 19:44:37.000000000 -0800
+++ build/make/Makefile 2018-02-08 07:00:14.000000000 -0800
@@ -199,7 +199,7 @@
@@ -200,7 +200,7 @@
$(qexec)$(AS) $(ASFLAGS) -o $@ $<

.PRECIOUS: %.c.S
@@ -1,6 +1,6 @@
--- build/make/configure.sh.orig 2018-02-06 19:44:37.000000000 -0800
+++ build/make/configure.sh 2018-02-07 05:49:18.000000000 -0800
@@ -729,33 +729,9 @@
--- build/make/configure.sh.orig 2019-02-09 23:18:41.000000000 -0800
+++ build/make/configure.sh 2019-02-09 23:29:38.000000000 -0800
@@ -770,37 +770,9 @@

# detect tgt_os
case "$gcctarget" in
@@ -32,11 +32,15 @@
- *darwin16*)
- tgt_isa=x86_64
- tgt_os=darwin16
- ;;
- *darwin17*)
- tgt_isa=x86_64
- tgt_os=darwin17
+ tgt_os=darwin
;;
x86_64*mingw32*)
tgt_os=win64
@@ -848,54 +824,6 @@
@@ -893,58 +865,6 @@
;;
esac

@@ -77,6 +81,10 @@
- add_cflags "-mmacosx-version-min=10.12"
- add_ldflags "-mmacosx-version-min=10.12"
- ;;
- *-darwin17-*)
- add_cflags "-mmacosx-version-min=10.13"
- add_ldflags "-mmacosx-version-min=10.13"
- ;;
- *-iphonesimulator-*)
- add_cflags "-miphoneos-version-min=${IOS_VERSION_MIN}"
- add_ldflags "-miphoneos-version-min=${IOS_VERSION_MIN}"
@@ -8,7 +8,7 @@
all_platforms="${all_platforms} x86-darwin8-gcc"
all_platforms="${all_platforms} x86-darwin8-icc"
all_platforms="${all_platforms} x86-darwin9-gcc"
@@ -141,6 +142,7 @@
@@ -139,6 +140,7 @@
all_platforms="${all_platforms} x86-win32-vs14"
all_platforms="${all_platforms} x86-win32-vs15"
all_platforms="${all_platforms} x86_64-android-gcc"
@@ -0,0 +1,10 @@
--- libs.mk.orig 2019-02-10 00:15:33.000000000 -0800
+++ libs.mk 2019-02-10 00:17:01.000000000 -0800
@@ -145,7 +145,6 @@
endif
CODEC_EXPORTS-yes += vpx/exports_com
CODEC_EXPORTS-$(CONFIG_ENCODERS) += vpx/exports_enc
-CODEC_EXPORTS-$(CONFIG_VP9_ENCODER) += vpx/exports_spatial_svc
CODEC_EXPORTS-$(CONFIG_DECODERS) += vpx/exports_dec

INSTALL-LIBS-yes += include/vpx/vpx_codec.h

0 comments on commit dd32ed8

Please sign in to comment.