Skip to content
Permalink
Browse files

xonsh: update to 0.7.10, add python37 variant

assume maintainership
  • Loading branch information
Schamschula committed Sep 28, 2018
1 parent ba6f803 commit e3e2daf6f2b16dfa1947a7689cdcda9f7e4fe166
Showing with 15 additions and 11 deletions.
  1. +15 −11 shells/xonsh/Portfile
@@ -4,11 +4,11 @@ PortSystem 1.0
PortGroup github 1.0
PortGroup python 1.0

github.setup xonsh xonsh 0.7.9
github.setup xonsh xonsh 0.7.10
github.tarball_from tags
categories shells
platforms darwin
maintainers nomaintainer
maintainers {mps @Schamschula} openmaintainer
license Permissive

description Xonsh is a Python-ish, BASHwards-looking shell language \
@@ -21,11 +21,11 @@ long_description ${description} \
macOS, and Windows. Xonsh is meant for the daily use of \
experts and novices alike.

checksums rmd160 376c32098a43b02f3175b5c72e34017abd8556a5 \
sha256 a83d21e5a8cfabb5a978b72869bba64425073ba3bac75a1fc28e3674819d0aca \
size 1954560
checksums rmd160 a90df0e52a9a11e33f8cc74aa5b476b6c9c9fe19 \
sha256 db747424acad588dac5e390ab1675aa0b32c3ec45cf16fa654202e3140210dab \
size 1955414

python.versions 34 35 36
python.versions 34 35 36 37

depends_lib-append port:py${python.version}-prompt_toolkit \
port:py${python.version}-pygments \
@@ -40,18 +40,22 @@ subport xonsh-devel {
}


variant python34 conflicts python35 python36 description {Use Python 3.4} {
variant python34 conflicts python35 python36 python37 description {Use Python 3.4} {
python.default_version 34
}

variant python35 conflicts python34 python36 description {Use Python 3.5} {
variant python35 conflicts python34 python36 python37 description {Use Python 3.5} {
python.default_version 35
}

variant python36 conflicts python34 python35 description {Use Python 3.6} {
variant python36 conflicts python34 python35 python37 description {Use Python 3.6} {
python.default_version 36
}

if {![variant_isset python34] && ![variant_isset python35]} {
default_variants +python36
variant python37 conflicts python34 python35 python36 description {Use Python 3.6} {
python.default_version 36
}

if {![variant_isset python34] && ![variant_isset python35] && ![variant_isset python36]} {
default_variants +python37
}

0 comments on commit e3e2daf

Please sign in to comment.
You can’t perform that action at this time.