Skip to content
Permalink
Browse files

Fix Travis CI Python issues by manually linking Python3

For some reason Homebrew started getting Python conflict issues with
Python linked to `python@2`. Add a manual force linking to python3 as a
before_install step.
  • Loading branch information
ychin committed Jan 30, 2020
1 parent 7e5d662 commit 2b49d949b3966745c5b9e942f29fe83bdf644fc7
Showing with 3 additions and 0 deletions.
  1. +3 −0 .travis.yml
@@ -29,6 +29,9 @@ anchors:
- python
- ruby
update: true
before_install:
# Homebrew has issues linking Python due to conflicts with Python2. Manually link in Python3.
- brew link --overwrite python3
- &lang_env
env: "LANGOPT='--enable-perlinterp=dynamic --enable-pythoninterp=dynamic --enable-python3interp=dynamic --enable-rubyinterp=dynamic --enable-luainterp=dynamic --with-lua-prefix=/usr/local'"
- &caches

0 comments on commit 2b49d94

Please sign in to comment.
You can’t perform that action at this time.