Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Unable to build with uglifier #559

Closed
jden opened this Issue · 3 comments

3 participants

@jden

I get the following when I run rake:

in /Users/jden/dev/zepto)
rake aborted!
Uglifier not available: no such file to load -- uglifier
/Users/jden/dev/zepto/Rakefile:47
(See full trace by running task with --trace)

Environment:

> gem list uglifier

*** LOCAL GEMS ***

uglifier (1.2.7)

> rake -V
rake, version 0.8.7

> ruby -v
ruby 1.8.7 (2011-12-28 patchlevel 357) [universal-darwin11.0]

> gem -v
1.3.6

Is this version of uglifier supported?

@thorlarholm

I have the exact same issue, with the exact same versions.

@thorlarholm

http://stackoverflow.com/a/10417859 has already helped me along the way.

In Ruby 1.8… You need to load rubygems before being able to require any other gem. This is not the case anymore with Ruby 1.9."

If I add require 'rubygems' before the require 'uglifier' then the rake build works.

@thorlarholm

Opened pull request #563 to fix this issue.

@mislav mislav closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.