Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Unable to build with uglifier #559

Closed
js-n opened this Issue Aug 3, 2012 · 3 comments

Comments

Projects
None yet
3 participants

js-n commented Aug 3, 2012

I get the following when I run rake:

in /Users/jden/dev/zepto)
rake aborted!
Uglifier not available: no such file to load -- uglifier
/Users/jden/dev/zepto/Rakefile:47
(See full trace by running task with --trace)

Environment:

> gem list uglifier

*** LOCAL GEMS ***

uglifier (1.2.7)

> rake -V
rake, version 0.8.7

> ruby -v
ruby 1.8.7 (2011-12-28 patchlevel 357) [universal-darwin11.0]

> gem -v
1.3.6

Is this version of uglifier supported?

Contributor

thorlarholm commented Aug 9, 2012

I have the exact same issue, with the exact same versions.

Contributor

thorlarholm commented Aug 9, 2012

http://stackoverflow.com/a/10417859 has already helped me along the way.

In Ruby 1.8… You need to load rubygems before being able to require any other gem. This is not the case anymore with Ruby 1.9."

If I add require 'rubygems' before the require 'uglifier' then the rake build works.

Contributor

thorlarholm commented Aug 9, 2012

Opened pull request #563 to fix this issue.

madrobby added a commit that referenced this issue Aug 9, 2012

@mislav mislav closed this Aug 12, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment