Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Issues VM presents for new users as of now #88

Closed
Juesto opened this issue Feb 27, 2018 · 11 comments

Comments

@Juesto
Copy link

@Juesto Juesto commented Feb 27, 2018

Using maemo-leste-1.0-amd64-virtual-20180207.vdi
Tested with VirtualBox 5.2.6
VM settings: Debian 64-bits or Linux 2.6 / 3.x / 4.x 64 bits. 1GB of RAM, 16MB of VRAM, 3D accel on. No Guest additions (Sluggish X!)
First boot warms about a symblink related to mtab (dont remember)
ACPI shutdown does not work (power button not working/cant test holding power button)
If X does not start up and instead drops into console: try removing -noreset from /etc/init.d/xorg to allow X to retry starting up.
SSH does not have root login enabled
VBox unlike vmware does not display console output properly, especially during shutdown. vmware does
tty encoding is ISO-8859-15 instead of UTF-8 (messed up debconf dialogs, etc)
packages to update: https://ptpb.pw/s4xV recommendation: not upgrade devuan stuff nor install elogind (devuan noise) and not upgrading policykit stuff. (disable the repos to be on the safe side just in case)
sample first upgrade without devuan repositories: https://ptpb.pw/TpOC
Current packages/After upgrade services seem to take too long to start but xorg and hildon does start ok. (aprox. time from startup until i can log in: ~4min https://ptpb.pw/59Rm ) desktop menu doesnt function.

@android-808

This comment has been minimized.

Copy link

@android-808 android-808 commented Feb 27, 2018

Virtual Box 5.2.2, same image as above. 32MB VRAM, 2GB RAM though.
After issues with Guest Additions to start with, I started again from the initial download image and they are now working fine. Certain updates require reboot (ie Update & Reboot -> Restarts with no X and some console messages - reboot -> Starts OK) but I have installed all updates (Devuan + Leste) up to the end of last week.
Changing to a console to log in as root does sometimes take a while for it to display login prompt but then works fine.

@Juesto Juesto closed this Feb 27, 2018
@Juesto Juesto reopened this Feb 27, 2018
@Juesto

This comment has been minimized.

Copy link
Author

@Juesto Juesto commented Feb 27, 2018

^ whoops accident

thanks for sharing your experience.
had issues with X at first and i wasn't updating the system, it was hit and miss. -noreset remedied the issue but it still didn't always start up. fresh working better for some weird reason it seems
starting from two updates ago the services take long to start and i think the bottleneck is either dbus or mce (?)

@android-808

This comment has been minimized.

Copy link

@android-808 android-808 commented Mar 3, 2018

Clean install with VBox 5.2.2 as I encountered the issue with initscripts. First boot no UI, second OK. Updates installed but terminal won't open in UI. Guest additions installed, no UI at all now.

Going to try with 5.2.8.
Edit: Terminal still wouldn't open - Internal Error message displayed. Switched to console, opened osso-xterm as root. Now Terminal seems to be ok from icon.
Edit2: Terminal issue still there

@Juesto

This comment has been minimized.

Copy link
Author

@Juesto Juesto commented Mar 3, 2018

mce isn't starting, can you ssh or getty?

@android-808

This comment has been minimized.

Copy link

@android-808 android-808 commented Mar 3, 2018

Don't use ssh so unfortunately haven't tried it. Check through the issues, there was one that had an issue with initscripts that needed manual intervention if upgraded between a certain time frame.

@Juesto

This comment has been minimized.

Copy link
Author

@Juesto Juesto commented Mar 3, 2018

interesting, will try new image later

@android-808 i prefer chat, do you mind joining us on irc? (easiness)

@android-808

This comment has been minimized.

Copy link

@android-808 android-808 commented Mar 3, 2018

The VM image hasn't been updated since the the 20180207 release. Upgrading from there should be ok MCE wise

@Juesto Recently I tend to only work on bits every now and again and don't spend as long working on projects when I do. Too easily distracted. Might go on irc during the week when I'm around.

@Juesto

This comment has been minimized.

Copy link
Author

@Juesto Juesto commented Mar 4, 2018

okay, by new image i meant whenever a new one is created.
yes it works fine but with the services weird delay
no problem! see you there ;)

@Juesto

This comment has been minimized.

Copy link
Author

@Juesto Juesto commented Mar 15, 2018

Turns out all platforms were suffering the X not starting issue because fmg forgot about how exec works!
in openrc/sysv/sh using exec means the script waits for the execution
in this case it's on dsme, dsme launches but it never reaches the point where it should wait for itself to finish warming up and it just causes a cascade of failures because it continues booting without waiting. maemo services are launched via dsmetool so they can be monitored by dsme for lifeguard purposes

@MerlijnWajer

This comment has been minimized.

Copy link
Member

@MerlijnWajer MerlijnWajer commented Mar 15, 2018

exec doesn't mean the script waits for the execution. But as I said - yes, removing the exec in front of the dsme call in /etc/init.d/dsme will fix this issue. @parazyd will do it tonight.

@Juesto

This comment has been minimized.

Copy link
Author

@Juesto Juesto commented Mar 16, 2018

best to use start-stop-daemon but might not work well with dsme on the long run

Update: maemo-leste-1.0-amd64-virtual-20180308 on vmware
VMWare guest tools work nicely but it partially stops working on reboot but it is not really necessary to have the additions.
services "hung" fixed because the image removed some osso-af-startup scripts(?) related issues: #83 #86

@Juesto Juesto closed this Mar 31, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.