problems loading the reporter #11

Closed
stevecrozz- opened this Issue May 22, 2013 · 4 comments

Comments

Projects
None yet
3 participants

f01289d introduces a new way of loading the reporter. The commit message says '__dirname gives problems'

Unfortunately the new way of loading with a static path to node_modules also has its own problems because in my case, grunt-template-jasmine-istanbul is loaded indirectly. It's in the node_modules folder of another module. So ./node_modules here actually points to the wrong path in my project, whereas __dirname works correctly.

I can't upgrade past 2.0.0 because if this issue.

Owner

maenu commented May 23, 2013

I think the reporter should be copied to jasmine's temp directory, as jasmine does with its own helpers.

maenu added a commit that referenced this issue May 26, 2013

Owner

maenu commented May 26, 2013

I changed how the paths are resolved on the master branch. But I did not yet publish it as a new version since I am not sure if it really resolves your issue. Could try it out by requiring the git repo as a dependency?

I had the exact same problem as @stevecrozz-rs, and after using this master branch as the dependency it worked perfectly for me.

Owner

maenu commented Aug 3, 2013

Perfect timing @christopherscott! Just when I'm finally ready to revive this project, you give me the confirmation for this issue, and I can continue on the master branch ;). Thanks a lot for the feedback. Since it's such a long time since I made the last changes, I'll retest my own projects with the master branch and check that these changes don't break anything.

@maenu maenu closed this in 2b25b14 Aug 10, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment