Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Configurable product addtocart with restAPI not working as expected #15028

Closed
yashpatadia36 opened this issue May 7, 2018 · 8 comments

Comments

@yashpatadia36
Copy link

commented May 7, 2018

Addtocart using same API work fine for simple product, but while adding configurable product with restAPI, it creates duplicate product entry in cart, it should ideally update the qty.
Using single store and quote id is also same.

Preconditions

  1. Magento 2.2.3 (with sample data)

Steps to reproduce

  1. Addtocart a configurable product from frontend.

image

  1. Create quote id with customer token, (http://local.magento.com/rest/default/V1/carts/mine)

  2. Addtocart same configurable product with rest API (http://local.magento.com/rest/default/V1/carts/mine/items)

Requets: { "cartItem": { "sku": "MJ12", "qty": 1, "quote_id": "11", "product_option": { "extension_attributes": { "configurable_item_options": [ { "option_id": "142", "option_value": "167" }, { "option_id": "93", "option_value": "49" } ] } } } }

Expected result

In cart there should be single product with two qty.

Actual result

image

@yashpatadia36 yashpatadia36 changed the title Configurable product addtocart restAPI and frontend store not synced Configurable product addtocart with restAPI not working as expected May 7, 2018

@yashpatadia36

This comment has been minimized.

Copy link
Author

commented May 7, 2018

@AlanJudi

This comment has been minimized.

Copy link

commented May 7, 2018

Dude, both links that you provided don't work!

@yashpatadia36

This comment has been minimized.

Copy link
Author

commented May 7, 2018

@engcom-backlog-nickolas

This comment has been minimized.

Copy link

commented Jul 17, 2018

Hello @yspeedwicked, thank you for your report. Unfortunately I'm not able to reproduce this issue.
peek 2018-07-17 15-51

Could you please add more details?

@yashpatadia36

This comment has been minimized.

Copy link
Author

commented Jul 26, 2018

@zamboten thanks this worked for me.

@engcom-backlog-nickolas can you please refer to its duplicate pull, #15720

Closing this issue.

@magento-engcom-team

This comment has been minimized.

Copy link
Contributor

commented Aug 8, 2018

Hi @yspeedwicked. Thank you for your report.
The issue has been fixed in #15720 by @zamboten in 2.2-develop branch
Related commit(s):

The fix will be available with the upcoming 2.2.7 release.

@sidolov

This comment has been minimized.

Copy link
Contributor

commented Aug 10, 2018

Hi @yspeedwicked. Thank you for your report.
The issue has been fixed in #17476 by @mage2pratik in 2.1-develop branch
Related commit(s):

The fix will be available with the upcoming 2.1.16 release.

@magento-engcom-team

This comment has been minimized.

Copy link
Contributor

commented Aug 11, 2018

Hi @yspeedwicked. Thank you for your report.
The issue has been fixed in #17475 by @mage2pratik in 2.3-develop branch
Related commit(s):

The fix will be available with the upcoming 2.3.0 release.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.