New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ACL not defined for Magento_Backend::web #3925

Closed
bpoiss opened this Issue Mar 30, 2016 · 5 comments

Comments

10 participants
@bpoiss

bpoiss commented Mar 30, 2016

The resource defined in magento/module-backend/etc/adminhtml/system.xml:440 (Magento_Backend::web) has no ACL. On the other hand there is an ACL defined for the resource Magento_Config::web that doesn't exist in magento/module-config/etc/acl.xml:22.

If you give some user role permissions for "Web Section" in the backend, the Web Section will not be visible for this user group.

@piotrekkaminski

This comment has been minimized.

Show comment
Hide comment
@piotrekkaminski

piotrekkaminski Jun 9, 2016

Contributor

Internal issue MAGETWO-54158

Contributor

piotrekkaminski commented Jun 9, 2016

Internal issue MAGETWO-54158

@vkorotun vkorotun removed the PS label Aug 4, 2016

@buskamuza buskamuza removed their assignment Aug 18, 2016

@vherasymenko

This comment has been minimized.

Show comment
Hide comment
@vherasymenko

vherasymenko May 11, 2017

Steps:

  1. Install Magento latest develop version
  2. Go to Admin side
  3. Click "System > User Roles"
  4. Click "Add new Role" enter Role name
  5. In left side choose Role Resources and check "Dashboard" and "Web Section"
  6. Save Role
  7. Click "System > All Users"
  8. Click "Add new User"
  9. Enter data in required fields
  10. In left side click "User Role" and choose early created role.
  11. Click "Save"
  12. Sign out and Log in using credentials of new user
  13. Click "Soters > Configuration"

AR: Displayer error
ER: Web Section should be visible for this user

vherasymenko commented May 11, 2017

Steps:

  1. Install Magento latest develop version
  2. Go to Admin side
  3. Click "System > User Roles"
  4. Click "Add new Role" enter Role name
  5. In left side choose Role Resources and check "Dashboard" and "Web Section"
  6. Save Role
  7. Click "System > All Users"
  8. Click "Add new User"
  9. Enter data in required fields
  10. In left side click "User Role" and choose early created role.
  11. Click "Save"
  12. Sign out and Log in using credentials of new user
  13. Click "Soters > Configuration"

AR: Displayer error
ER: Web Section should be visible for this user

@jspoe

This comment has been minimized.

Show comment
Hide comment
@jspoe

jspoe May 13, 2017

Collaborator

Created pull request for fixing this issue.
Also changed some other similar ACL problems along the way.

#9628

Collaborator

jspoe commented May 13, 2017

Created pull request for fixing this issue.
Also changed some other similar ACL problems along the way.

#9628

@okorshenko okorshenko added this to Pull Request In Progress in Community Dashboard May 28, 2017

magento-team pushed a commit that referenced this issue Jul 5, 2017

Merge pull request #1273 from magento-performance/PERFORMANCE-BUG-FIXES
Fixed issues:
MAGETWO-54158 [Github] ACL not defined for Magento_Backend::web #3925
MAGETWO-59467 Checkbox "User Defined" is visible for bundle product option with input type checkbox and multi select
MAGETWO-59900 Wrong order total after refresh in admin order create page
MAGETWO-70066 Significant memory usage of CatalogPermissions indexer with big number of customer groups
MAGETWO-58862 Admin session lifetime is always 0
@AVoskoboinikov

This comment has been minimized.

Show comment
Hide comment
@AVoskoboinikov

AVoskoboinikov Jul 6, 2017

Contributor

Hi guys!
Fix was delivered with this commit 686df6b

Contributor

AVoskoboinikov commented Jul 6, 2017

Hi guys!
Fix was delivered with this commit 686df6b

@korostii

This comment has been minimized.

Show comment
Hide comment
@korostii

korostii Jul 6, 2017

@AZVO, delivered to develop only, it seems, right?
I think it's a bit misleading and way too early to close the issue if it is still reproducible on latest stable (2.1.7 at the moment) release. Don't you agree?

korostii commented Jul 6, 2017

@AZVO, delivered to develop only, it seems, right?
I think it's a bit misleading and way too early to close the issue if it is still reproducible on latest stable (2.1.7 at the moment) release. Don't you agree?

@ishakhsuvarov ishakhsuvarov moved this from Pull Request In Progress to Done in Community Dashboard Jul 18, 2017

@magento-engcom-team magento-engcom-team moved this from TODO to Done in branch [2.3-develop] Sep 12, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment