Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fotorama Gallery too sensitive on Android Devices. (chrome) #7906

Closed
joebordo opened this issue Dec 20, 2016 · 14 comments
Closed

Fotorama Gallery too sensitive on Android Devices. (chrome) #7906

joebordo opened this issue Dec 20, 2016 · 14 comments

Comments

@joebordo
Copy link

@joebordo joebordo commented Dec 20, 2016

2 Problems because of Chrome Update.

I think this happend after Chrome update...(something changed in chrome)
Everything used to work fine...i think until couple of days ago...i noticed my chrome got updated on my android phone and so seems to be my pc chrome.

Preconditions

  1. Magento 2.1.3, 2.1.2, 2.1.1
  2. Use Chrome Dev tools=>mobile view, with touch, or Chrome in Android Phone

Steps to reproduce

You can even use this demo page.
Go with your android mobile, or google developer tools, mobile view to the following page.
http://magento2-demo.nexcess.net/radiant-tee.html

Edit: This link has more images.:
http://alothemes.com/demo2/supermarket/index.php/favorite-izon-cameras.html

So basycally all themeforest themes...can be checked...

Then swipe right or left. The image swipes instantly. You can't grab the image, hold it and control it.
It used to work normal before, but i think after chrome update...things changed.
It's bad because if you try to scroll down, it always triggers the swipe...
It also feels that you are not the one swiping.

On Iphone it works fine. ON my LG G4 "internal browser"=not chrome" it also works fine.
Alot of visitors use chrome...so it's really important.

Expected result

Problem 1
You should be able to swipe hold it, and let it go. To fully contorl your swipes like before.
It should not trigger a swipe when you scroll down.
Problem 2
The thumbnav slider becomes really hard to scroll. Like it has alot of friction.

Actual result

Problem 1
It triggers the swipe and makes it look messy. Just keep scrolling down on the image...it keeps getting triggered. While being scrolled it is also being swiped.
Problem 2
The user should be able to scroll easy...and smooth.

PS: I just downloaded latest fotorama 4.6.4 uncompressed and replaced it with my magento fotorama.js in lib folder.
That one works! No problem at all...but it's not fully coded with magento variables...the magento fotorama.js has been modified to work properly with magento.

So the problem is with the fotorama.js of magento.

If you can"t replicate the problem, let me know i will make a video and put it on youtube.

Ps: This is only on Android, chrome which alot of users use. I tried on safari and chrome on ipad and everything seems fine.
I hope someone can find a fix.

@joebordo

This comment has been minimized.

Copy link
Author

@joebordo joebordo commented Dec 21, 2016

Coman guys, anyone? I can't sleep. It's really bugging me. I don't know what to do.

Edit: So what i found out is really weard. Fotorama had this scroll down problem right? Now using the old "fotorama of 2.0 or 2.1" without the fix for it to know if you wanna scroll down or swipe...it works.

So it's defently the chrome update.

It's still a mystery why the original from fotorama.io behaves normal.

@jupiter01

This comment has been minimized.

Copy link

@jupiter01 jupiter01 commented Dec 21, 2016

We replaced fotorama with magic zoom. Less issues on mobile. Just a suggestion if you cant sort your issue.

@joebordo

This comment has been minimized.

Copy link
Author

@joebordo joebordo commented Dec 21, 2016

The problem is not fotorama it self , but the way they implemented the gallery.
I'm now going 1 line by 1 line over 3000 lines with the original fotorama.js to see what they did different to find out why magento version behaves the way it does, but not the original.

and i'm not a javascript developer lol. I know it's a tiny easy peacy thing...but no one except you replies :(

Thanks !

@joebordo

This comment has been minimized.

Copy link
Author

@joebordo joebordo commented Dec 21, 2016

Okey, found it.

Line: 1508

  $el.on('mousedown pointerdown', onStart);
            $DOCUMENT
                .on('mousemove pointermove', onMove)
                .on('mouseup pointerup', onEnd);
        }

Get rid of the "pointerDown en pointermove stuff...

So it becomes.

     $el.on('mousedown', onStart);
            $DOCUMENT
                .on('mousemove', onMove)
                .on('mouseup', onEnd);
        }
@joebordo joebordo closed this Dec 21, 2016
@jupiter01

This comment has been minimized.

Copy link

@jupiter01 jupiter01 commented Dec 21, 2016

You probably should of left this open if it hinders user interaction. Could be something the dev team needs to look into. In any event, glad you found a solution.

@joebordo joebordo reopened this Dec 21, 2016
@joebordo

This comment has been minimized.

Copy link
Author

@joebordo joebordo commented Dec 21, 2016

You are right. I just reopened.Thanks! Hope it helps others.

@magento-engcom-team

This comment has been minimized.

Copy link
Contributor

@magento-engcom-team magento-engcom-team commented Nov 1, 2017

@joebordo, thank you for your report.
We've created internal ticket(s) MAGETWO-83114 to track progress on the issue.

@magento-engcom-team

This comment has been minimized.

Copy link
Contributor

@magento-engcom-team magento-engcom-team commented Mar 22, 2018

Hi @joebordo. Thank you for your report.
The issue has been fixed in #14123 by @DaniloEmpire in 2.3-develop branch
Related commit(s):

The fix will be available with the upcoming 2.3.0 release.

@jupiter01

This comment has been minimized.

Copy link

@jupiter01 jupiter01 commented Mar 22, 2018

2.3 release date?

@Ilchuk

This comment has been minimized.

Copy link

@Ilchuk Ilchuk commented Nov 2, 2018

#mageconf

@magento-engcom-team

This comment has been minimized.

Copy link
Contributor

@magento-engcom-team magento-engcom-team commented Nov 2, 2018

@Ilchuk thank you for joining. Please accept team invitation here and self-assign the issue.

@magento-engcom-team

This comment has been minimized.

Copy link
Contributor

@magento-engcom-team magento-engcom-team commented Nov 15, 2018

Hi @TomashKhamlai. Thank you for working on this issue.
Looks like this issue is already verified and confirmed. But if your want to validate it one more time, please, go though the following instruction:

  • 1. Add/Edit Component: XXXXX label(s) to the ticket, indicating the components it may be related to.

  • 2. Verify that the issue is reproducible on 2.3-develop branch

    Details- Add the comment @magento-engcom-team give me 2.3-develop instance to deploy test instance on Magento infrastructure.
    - If the issue is reproducible on 2.3-develop branch, please, add the label Reproduced on 2.3.x.
    - If the issue is not reproducible, add your comment that issue is not reproducible and close the issue and stop verification process here!

  • 3. Verify that the issue is reproducible on 2.2-develop branch.

    Details- Add the comment @magento-engcom-team give me 2.2-develop instance to deploy test instance on Magento infrastructure.
    - If the issue is reproducible on 2.2-develop branch, please add the label Reproduced on 2.2.x

  • 4. If the issue is not relevant or is not reproducible any more, feel free to close it.

@TomashKhamlai

This comment has been minimized.

Copy link
Contributor

@TomashKhamlai TomashKhamlai commented Nov 15, 2018

The issue was re-tested and we can confirm that it was fixed on the 2.3 release branch. We closing this issue as fixed due to upcoming 2.3 release that will be available soon.

2 3 0-magento-trim

@magento-engcom-team

This comment has been minimized.

Copy link
Contributor

@magento-engcom-team magento-engcom-team commented Apr 17, 2019

Hi @joebordo. Thank you for your report.
The issue has been fixed in #22078 by @Nazar65 in 2.2-develop branch
Related commit(s):

The fix will be available with the upcoming 2.2.9 release.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.