ImportExport: Fix notice if _attribute_set column is missing #325

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
4 participants
@amenk
Contributor

amenk commented Jul 24, 2013

There are cases, especially when custom import adapters are used, where _attribute_set is not defined in a $row (not for the initial row of course). This is not a problem - but causes a notice.

ImportExport: Fix notice if _attribute_set column is missing
There are cases, especially when custom import adapters are used, where _attribute_set is not defined in a $row (not for the initial row of course). This is not a problem - but causes a notice.
@ihor-sviziev

This comment has been minimized.

Show comment Hide comment
@ihor-sviziev

ihor-sviziev Aug 5, 2013

Contributor

See http://php.net/manual/en/function.isset.php
Determine if a variable is set and is not NULL.

You can use

isset($rowData[self::COL_ATTR_SET])

instead of

isset($rowData[self::COL_ATTR_SET]) && !is_null($rowData[self::COL_ATTR_SET])

I think it's should be better

Contributor

ihor-sviziev commented Aug 5, 2013

See http://php.net/manual/en/function.isset.php
Determine if a variable is set and is not NULL.

You can use

isset($rowData[self::COL_ATTR_SET])

instead of

isset($rowData[self::COL_ATTR_SET]) && !is_null($rowData[self::COL_ATTR_SET])

I think it's should be better

@verklov

This comment has been minimized.

Show comment Hide comment
@verklov

verklov Nov 7, 2013

Contributor

Hello amenk,
Sorry for the delay with the response.
Thank you for your contribution! Our team will review your pull request and respond as soon as our analysis is complete.

Contributor

verklov commented Nov 7, 2013

Hello amenk,
Sorry for the delay with the response.
Thank you for your contribution! Our team will review your pull request and respond as soon as our analysis is complete.

@tim-bezhashvyly

This comment has been minimized.

Show comment Hide comment
@tim-bezhashvyly

tim-bezhashvyly Apr 6, 2014

Contributor

+1 for accepting this pull request. I got my system.log constantly trashed with "_attribute_set is not defined" notices.

Contributor

tim-bezhashvyly commented Apr 6, 2014

+1 for accepting this pull request. I got my system.log constantly trashed with "_attribute_set is not defined" notices.

magento-team added a commit that referenced this pull request Apr 7, 2014

2.0.0.0-dev72
* Framework Improvements:
  * Fixed performance degradation caused by DI argument processors
* Modularity improvements:
  * Introduced the Magento_UrlRewrite module, and moved corresponding classes from Magento_Core to Magento_UrlRewrite
  * Moved all Install logic to the Magento_Install module
  * Eliminated the Core\Helper\Js class
  * Moved the Email related logic from the Magento_Core module to the Magento_Email module
  * Moved the Cache related logic from the Magento_Core module to library
* Indexer improvements:
  * Added execution time hints for console reindex
* Customer Service usage:
  * Refactored the Magento_Newsletter module to use Customer service layer
* Fixed bugs:
  * Fixed an issue with resetting customer password from the frontend
  * Fixed an issue where mistakenly the attribute of the Customer Address Edit form was cached
  * Fixed an issue where admin could not unsubscribe customer on the customer edit page in the backend
  * Fixed an issue where customers were always subscribed to the newsletter even if not selected during registration
* GitHub requests:
  * [#325] (#325) -- ImportExport: Fix notice if _attribute_set column is missing
@verklov

This comment has been minimized.

Show comment Hide comment
@verklov

verklov Apr 8, 2014

Contributor

@amenk, the team has accepted your contribution. We released the fix to the Github. In fact, the issus was fixed a bit earlier, but for some reason we lost the record in the changelog. Thus, we are restoring justice this time :) We are closing this issue.

Contributor

verklov commented Apr 8, 2014

@amenk, the team has accepted your contribution. We released the fix to the Github. In fact, the issus was fixed a bit earlier, but for some reason we lost the record in the changelog. Thus, we are restoring justice this time :) We are closing this issue.

@verklov verklov closed this Apr 8, 2014

@amenk amenk deleted the amenk:patch-6 branch Apr 8, 2014

magento-team pushed a commit that referenced this pull request May 29, 2015

Merge pull request #325 from magento-api/develop
[API] Sprint 49 Bugfixes + Task

okorshenko added a commit that referenced this pull request Jan 20, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment