Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

LOC capturing issues #152

Closed
GlitchedYT opened this issue Oct 14, 2019 · 7 comments
Closed

LOC capturing issues #152

GlitchedYT opened this issue Oct 14, 2019 · 7 comments
Assignees
Labels
Milestone

Comments

@GlitchedYT
Copy link

@GlitchedYT GlitchedYT commented Oct 14, 2019

Describe the bug
I'm not completely sure if this is just due to the fact that this plane uses the default fmc or not, but for the last 4 ILS landings i've done, the LOC capture keeps the plane way to the left or the right at about a 45 degree angle to the runway instead of lining it up with the center lines. The plane captures the LOC fine but doesn't line it up well at all. Like i said not sure if the is just because it's using the default fmc or just a bug altogether.. From what i've seen, the system is just lining it up with the direction of the runway in general rather than the heading/center line of the actual runway

Expected behavior
When the LOC captures it should line the plane up with the runway's heading/center line rather than stay way to the left or the right pointing at a 45 degree angle to the runway.

Screenshots
Didn't take any screenshots prior to posting this but i'll add some the next time i try an ILS landing

Desktop (please complete the following information):

  • Windows 10
  • X-Plane 11.36
  • Version 1.4 beta2
@daza10
Copy link

@daza10 daza10 commented Oct 16, 2019

Had the same behaviour on approach to 07R KLAX.

@aeroniemi
Copy link
Member

@aeroniemi aeroniemi commented Oct 17, 2019

is the plane switching to NAV1/NAV2 correctly?
to find out, check the status of sim/cockpit2/radios/actuators/HSI_source_select_pilot

@aeroniemi aeroniemi added the bug label Oct 17, 2019
@aeroniemi aeroniemi self-assigned this Oct 17, 2019
@aeroniemi aeroniemi added this to the 1.4.0 milestone Oct 18, 2019
@GlitchedYT
Copy link
Author

@GlitchedYT GlitchedYT commented Oct 18, 2019

Am I able to just send you that file, or do I have to do an old approach for it to show in the file

@daza10
Copy link

@daza10 daza10 commented Oct 19, 2019

Tried 2 more approaches to KLAX 07R. 1 was to the right of the centre line - just on the runway. 2nd was way to the right - missing the runway. Both had nav1 & 2 dialled to ILS and both courses using runway direction (071).
Need to try different airport to see if it’s just KLAX.

@aeroniemi
Copy link
Member

@aeroniemi aeroniemi commented Oct 19, 2019

Tried 2 more approaches to KLAX 07R. 1 was to the right of the centre line - just on the runway. 2nd was way to the right - missing the runway. Both had nav1 & 2 dialled to ILS and both courses using runway direction (071).
Need to try different airport to see if it’s just KLAX.

is the plane switching to NAV1/NAV2 correctly?
to find out, check the status of sim/cockpit2/radios/actuators/HSI_source_select_pilot in datareftool

@daza10
Copy link

@daza10 daza10 commented Oct 20, 2019

The above value in datareftool shows 0. Took off and landed at KLAX and at no point did it change.

@daza10
Copy link

@daza10 daza10 commented Oct 21, 2019

Just an update. Can see HSI_Source_Select is switching correctly. Shows 2 when on FMC navigation then switches to zero when approach selected. Still doesn’t come in on centre line though - usually left or right off the runway (just on).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants