Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

magnars optimus:- Does not support windows environment #28

Open
dchakrawarti opened this Issue Jun 26, 2014 · 1 comment

Comments

Projects
None yet
2 participants

I am trying to use this lib in my project but geting this exception: (tried on both windows xp / 7)

Exception in thread "main" java.lang.Exception: Unsupported OS/archetype: Windows XP x86, compiling:(core.clj:36:1)
at clojure.lang.Compiler$InvokeExpr.eval(Compiler.java:3463)
at clojure.lang.Compiler.compile1(Compiler.java:7153)
at clojure.lang.Compiler.compile(Compiler.java:7219)
at clojure.lang.RT.compile(RT.java:398)
at clojure.lang.RT.load(RT.java:438)
at clojure.lang.RT.load(RT.java:411)

Owner

magnars commented Jun 26, 2014

Yes, unfortunately clj-v8 does not come with binaries for windows.

Please open an issue on the clj-v8 issue tracker, maybe that will help: https://github.com/circleci/clj-v8

Otherwise there is this issue, with talk about changing JavaScript engine - but that would then require Java 8 instead: #14

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment