New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Dovecot - "Invalid settings: postmaster_address setting not given" #31

Closed
xxdesmus opened this Issue Apr 24, 2014 · 3 comments

Comments

Projects
None yet
4 participants
@xxdesmus
Copy link

xxdesmus commented Apr 24, 2014

After a clean install it seems I can send email just fine, but receiving is a problem.

Checking /var/log/syslog I see this:

Invalid settings: postmaster_address setting not given

Here's the full block of the incoming email:

Apr 24 00:27:56 mail postfix/smtpd[24841]: connect from mail-vc0-f171.google.com[209.85.220.171]
Apr 24 00:27:56 mail postgrey[7956]: action=pass, reason=client whitelist, client_name=mail-vc0-f171.google.com, client_address=209.85.220.171, sender=NAME@gmail.com, recipient=NAME@DOMAIN
Apr 24 00:27:56 mail postfix/smtpd[24841]: 689491610F0: client=mail-vc0-f171.google.com[209.85.220.171]
Apr 24 00:27:56 mail postfix/cleanup[24844]: 689491610F0: message-id=<CAH=oei_D8NrJ5T_zwSasKzfJwLh0a7uf=W-1Vx-T2PqhozryzQ@mail.gmail.com>
Apr 24 00:27:56 mail opendkim[15755]: 689491610F0: s=20120113 d=gmail.com SSL
Apr 24 00:27:56 mail postfix/qmgr[9306]: 689491610F0: from=<NAME@gmail.com>, size=1851, nrcpt=1 (queue active)
Apr 24 00:27:56 mail dovecot: lmtp(24846): Fatal: Error reading configuration: Invalid settings: postmaster_address setting not given

I had to add:

postmaster_address=postmaster at DOMAIN

Change DOMAIN with your actual domain obviously.

to

/etc/dovecot/dovecot.conf

and then

service dovecot restart

All good now.

@JoshData JoshData closed this in 07b43c2 Apr 24, 2014

@JoshData

This comment has been minimized.

Copy link
Member

JoshData commented Apr 24, 2014

Thanks for reporting the issue!

I wasn't getting this error on mine, but I've patched the mail setup to set the configuration option now.

@jinxingvenus

This comment has been minimized.

Copy link

jinxingvenus commented Oct 20, 2014

Thank xxdesmus ,i have the same problem.
Can not send mail ,
in postfix log infor the following:


"[private/dovecot-lmtp], delay=240270, delays=240270/0.02/0/0, dsn=4.4.2, status=deferred (lost connection with mail.xxx.com[private/dovecot-lmtp] while receiving the initial server greeting)"


then open dovecot debug log,infor us the following:
+++++++++++++++++++++++++++++++++++++++++++++++++++
Invalid settings: postmaster_address setting not given
++++++++++++++++++++++++++++++++++++++++++++++++++++
then according your method .solve this issue.
My environment is:
reinstall Postfix+dovecot+LNMP+Postfixadmin+Roundemail+clamav+amais-new+spamassassin
and change mysql DB host. install from source.
first install is ok. reinstall have occur the above issue.
Br

@Jannik2017

This comment has been minimized.

Copy link

Jannik2017 commented Feb 10, 2017

how ic can fix this

eu,)Error: Error reading configuration: Invalid settings: postmaster_address set ting not given lda: Fatal: Internal error occurred. Refer to server log for more information. 4.2.1 Message can not be delivered at this time )

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment