Support for newer plesk versions (10.2+) #5

Closed
gggeek opened this Issue Apr 1, 2011 · 2 comments

Comments

Projects
None yet
3 participants
@gggeek

gggeek commented Apr 1, 2011

Apparently starting with 10.2, the pwd in .psa.shadow is crypted; You need to read it via
/usr/local/psa/bin/admin –show-password
instead of
cat /etc/psa/.psa.shadow

While at it: why not change
$mysqllogin = "-u admin -pcat /etc/psa/.psa.shadow";
to
$mysqllogin = "-u admin -p'cat /etc/psa/.psa.shadow'";

are we sure that .psa.shadow alwyas contains quotes by default?

@mnikhil-git

This comment has been minimized.

Show comment Hide comment
@mnikhil-git

mnikhil-git Dec 31, 2011

what is the difference here? I mean how is passwd in .psa.shadow encrypted if it can show the password right by executing admin --show-password command. Does it ask for a password/or a encryption key?

what is the difference here? I mean how is passwd in .psa.shadow encrypted if it can show the password right by executing admin --show-password command. Does it ask for a password/or a encryption key?

@major

This comment has been minimized.

Show comment Hide comment
@major

major Feb 22, 2014

Owner

Sorry for the long delay. Is there still a change that needs to be made?

Owner

major commented Feb 22, 2014

Sorry for the long delay. Is there still a change that needs to be made?

@major major closed this Feb 22, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment