PhantomJS not captured #540

Open
Asherlc opened this Issue Sep 6, 2016 · 1 comment

Projects

None yet

2 participants

@Asherlc
Asherlc commented Sep 6, 2016

Trying to run the test suite, with PhantomJS 2.1.1 installed, and get this error:

Vendor files: tests/vendor/jquery-1.11.2.min.js, tests/vendor/bootstrap-3.3.2.min.js
(node:20900) DeprecationWarning: process.EventEmitter is deprecated. Use require('events') instead.
INFO [karma]: Karma v0.10.10 server started at http://localhost:9876/
INFO [launcher]: Starting browser PhantomJS
WARN [launcher]: PhantomJS have not captured in 60000 ms, killing.
INFO [launcher]: Trying to start PhantomJS again.
WARN [launcher]: PhantomJS have not captured in 60000 ms, killing.
INFO [launcher]: Trying to start PhantomJS again.
WARN [launcher]: PhantomJS have not captured in 60000 ms, killing.
@makeusabrew
Owner

The test suite seemed to break with newer node versions and slight discrepancies between npm packages. If you update now, remove node_modules and run a fresh npm install, it should work as expected.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment