Skip to content

Bump bytestring upper bound to allow use of 0.10 #7

Merged
merged 1 commit into from Sep 10, 2012

3 participants

@gregorycollins

The package still doesn't build on ghc-7.6, of course, because Duncan still needs to twiddle the deps in zlib. But we'll get there :-(

@maltem maltem merged commit 36a8188 into maltem:master Sep 10, 2012
@hvr
hvr commented Sep 13, 2012

A ghc-7.6 compatible zlib-0.5.4.0 has been released a couple of hours ago; now the only thing missing is an upload of the current zlib-enum HEAD to Hackage... :-)

@maltem
Owner
maltem commented Sep 13, 2012

Will do this evening. I'm idly wondering, though, if I shouldn't just lift all upper version bounds (probably excepting base, just as Michael did for zlib-bindings). Putting them in was the mode du jour at the time, but it basically just brought up the problem that we have to keep updating them, which defeats the purpose of having them in the first place.

@hvr
hvr commented Sep 13, 2012

FWIW, here's a counter-example, just take a look at

http://hackage.haskell.org/package/tar-0.4.0.0

which has no upper-version bounds and is seriously broken for directory>=1.2, and CABAL has no chance to find a working combination by itself (if it had a upper version bound, it could avoid compiling against the non-compatible directory-1.2.0.0, which results in a failure which aborts further backtracking attempts)

IMHO, just leaving out upper-version bounds doesn't solve the cabal-hell-problem either w/o any additional measure to ensure that "historic" versions still build in the presence of newer versions of the dependencies...

@maltem
Owner
maltem commented Sep 13, 2012

Ok.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.