The package still doesn't build on ghc-7.6, of course, because Duncan still needs to twiddle the deps in zlib. But we'll get there :-(
Bump bytestring upper dependency to allow 0.10
A ghc-7.6 compatible zlib-0.5.4.0 has been released a couple of hours ago; now the only thing missing is an upload of the current zlib-enum HEAD to Hackage... :-)
Will do this evening. I'm idly wondering, though, if I shouldn't just lift all upper version bounds (probably excepting base, just as Michael did for zlib-bindings). Putting them in was the mode du jour at the time, but it basically just brought up the problem that we have to keep updating them, which defeats the purpose of having them in the first place.
FWIW, here's a counter-example, just take a look at
which has no upper-version bounds and is seriously broken for directory>=1.2, and CABAL has no chance to find a working combination by itself (if it had a upper version bound, it could avoid compiling against the non-compatible directory-184.108.40.206, which results in a failure which aborts further backtracking attempts)
IMHO, just leaving out upper-version bounds doesn't solve the cabal-hell-problem either w/o any additional measure to ensure that "historic" versions still build in the presence of newer versions of the dependencies...