Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Can not find ruby test script![ubuntu] #193

Closed
crosspass opened this Issue · 2 comments

3 participants

Wu Yingchao Grzegorz Smajdor Matthew Turney
Wu Yingchao

sublime2, configuration file all set OK, but when run rubytest happen error!
"ruby: no Ruby script found in input (LoadError)"

I open sublime console and find that as following when i run rubytes .Therefor I copy this command run that dose not work yet.
Running /home/zfk/.rvm/bin/rvm-auto-ruby -S bundle exec rspec spec/requests/static_pages_spec.rb -l38

Traceback (most recent call last):
File "./sublime_plugin.py", line 270, in is_enabled_
File "./run_ruby_test.py", line 324, in is_enabled
File "./run_ruby_test.py", line 299, in file_type
File "./run_ruby_test.py", line 139, in load_config
File "./run_ruby_test.py", line 157, in bundler_support
File "./run_ruby_test.py", line 224, in find_project_root
AttributeError: 'AnonymousFile' object has no attribute 'partition_folder'
Traceback (most recent call last):

Grzegorz Smajdor
Collaborator
gs commented

is this still valid?

Wu Yingchao crosspass closed this
Matthew Turney

I'm running on ST3 and getting this exact error. Have been for quite some time, although RubyTest still seems to run fine. It usually happens when restarting sublimetext while loading the plugins.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.