Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't use XDebug with PHP 7.3 #305

Closed
Kocal opened this Issue Mar 4, 2019 · 2 comments

Comments

Projects
None yet
2 participants
@Kocal
Copy link
Contributor

Kocal commented Mar 4, 2019

Hi, I'm facing an issue while trying to use XDebug with PHP 7.3 (it worked fine with PHP 7.2).

Just after running manala_php_xdebug on:
502 bad gateway - google chrome_282

The Nginx configuration seems to be valid:
selection_283

Nginx and PHP-FPM logs:
app yprox -srv-app_285

If I run manala_php_xdebug off, everything goes fine.

@Kocal

This comment has been minimized.

Copy link
Contributor Author

Kocal commented Mar 4, 2019

Well, in fact I found how to fix the issue while I was writing the previous post, but I prefer keep a trace here if someone has the same issue.

It happened to laravel/valet too laravel/valet#685 and it has been fixed in xdebug/xdebug#438.

A simple sudo apt update, sudo apt upgrade, and sudo service php7.3-fpm (otherwise you can have the error Attempted to call function "apcu_fetch" from the global namespace.) and Xdebug finally works:
selection_286

@Kocal Kocal closed this Mar 4, 2019

@nervo

This comment has been minimized.

Copy link
Member

nervo commented Mar 4, 2019

Good to know, thx @Kocal !

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.