Permalink
Browse files

Improved the setup

  • Loading branch information...
1 parent 22049ef commit 93e8b85756503dfa313b295321b3b6ccc2ac2b79 Diptanu Choudhury committed Dec 15, 2011
Showing with 4 additions and 40 deletions.
  1. +1 −0 .gitignore
  2. +0 −38 MANIFEST
  3. +3 −2 setup.py
View
@@ -1,3 +1,4 @@
+mangrove.egg-info
.idea
dist
*.pyc
View
@@ -1,38 +0,0 @@
-# file GENERATED by distutils, do NOT edit
-setup.py
-mangrove/__init__.py
-mangrove/initializer.py
-mangrove/validate.py
-mangrove/datastore/__init__.py
-mangrove/datastore/aggregationtree.py
-mangrove/datastore/aggregrate.py
-mangrove/datastore/data.py
-mangrove/datastore/database.py
-mangrove/datastore/datadict.py
-mangrove/datastore/documents.py
-mangrove/datastore/entity.py
-mangrove/datastore/entity_type.py
-mangrove/datastore/initializer.py
-mangrove/datastore/queries.py
-mangrove/datastore/settings.py
-mangrove/datastore/time_period_aggregation.py
-mangrove/errors/MangroveException.py
-mangrove/errors/__init__.py
-mangrove/form_model/__init__.py
-mangrove/form_model/field.py
-mangrove/form_model/form_model.py
-mangrove/form_model/initializer.py
-mangrove/form_model/validation.py
-mangrove/form_model/validators.py
-mangrove/georegistry/__init__.py
-mangrove/georegistry/api.py
-mangrove/transport/__init__.py
-mangrove/transport/reporter.py
-mangrove/transport/submissions.py
-mangrove/utils/__init__.py
-mangrove/utils/dates.py
-mangrove/utils/geo_utils.py
-mangrove/utils/google_spreadsheets.py
-mangrove/utils/helpers.py
-mangrove/utils/json_codecs.py
-mangrove/utils/types.py
View
@@ -1,3 +1,4 @@
+from setuptools import find_packages
from distutils.core import setup
setup(name='mangrove',
@@ -6,5 +7,5 @@
author='ThoughtWorks',
author_email='mangroveorg@googlegroups.com',
url='https://github.com/mangroveorg/mangrove/',
- packages=['mangrove', 'mangrove.datastore', 'mangrove.errors', 'mangrove.form_model', 'mangrove.georegistry', 'mangrove.transport', 'mangrove.utils'],
- requires=["nose", "CouchDB", "coverage", "simplejson", "mock", "iso8601", "pytz", "xlwt"])
+ packages=find_packages(),
+ requires=["nose (==1.0.0)", "CouchDB (==0.8)", "coverage (==3.4)", "simplejson", "mock", "iso8601", "pytz", "xlwt"])

0 comments on commit 93e8b85

Please sign in to comment.