CLI that checks whether your pypi requirements are up to date
Python
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
pypiup Bump 0.0.3 Jul 21, 2017
requirements
tests
.gitignore
.travis.yml
LICENSE
MANIFEST.in
README.md
requirements.txt
runtests.py
setup.py

README.md

pypiup travis codecov pypi

Check whether your PyPI requirements are up to date. Demo

press

Installation

You can install pypiup through pypi.

sudo pip install pypiup

Usage

The command you can use is pypiup. Use --help to see all the available options.

> pypiup --help
Usage: pypiup [OPTIONS]

  PyPIup
  Check whether your PyPI requirements are up to date.

Options:
  -r, --requirement TEXT  Specify the path of the requirements file. Defaults
                          to "requirements.txt".
  -d, --demo              Load the demo requirements.txt file that comes with
                          the package.
  --help                  Show this message and exit.

Development

pyvenv env
source env/bin/activate

pip install -r requirements.txt
python pypiup/cli.py --help
python pypiup/cli.py --demo

Tests

In order to run the tests you will have to run:

python runtests.py

Contributing

  1. Fork it!
  2. Create your feature branch: git checkout -b my-new-feature
  3. Commit your changes: git commit -am 'Add some feature'
  4. Push to the branch: git push origin my-new-feature
  5. Submit a pull request
  6. Make sure tests are passing