Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

2.8.0 returns NULL instead of an empty string for an empty MVA #160

Closed
dennis-gr opened this Issue Jan 29, 2019 · 2 comments

Comments

Projects
None yet
3 participants
@dennis-gr
Copy link

dennis-gr commented Jan 29, 2019

Describe the environment

**Manticore Search version: 2.8.0

Description of the issue:

Since 2.8.0 Manticore returns NULL instead of an empty string for a MVA with no values. This breaks existing code that assumes a non-NULL will returned in that case.

Server version: 2.7.5 4a31c54@181204 release

Copyright (c) 2000, 2018, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> select actor_id from sakila where id = 257;
 ---------- 
| actor_id |
 ---------- 
|          |
 ---------- 
1 row in set (0.00 sec)
Server version: 2.8.0 4006794b@190128 release

Copyright (c) 2000, 2018, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> select actor_id from sakila where id = 257;
 ---------- 
| actor_id |
 ---------- 
| NULL     |
 ---------- 
1 row in set (0.00 sec)
@tomatolog

This comment has been minimized.

Copy link
Contributor

tomatolog commented Jan 29, 2019

seems like regression of c8b73dc.
I'll inform you on this will be fixed.

@tomatolog tomatolog added the bug label Jan 29, 2019

@githubmanticore githubmanticore changed the title 2.8.0 returns NULL instead of an empty string for an empty MVA 2.8.0 returns NULL instead of an empty string for an empty MVA Jan 29, 2019

@tomatolog

This comment has been minimized.

Copy link
Contributor

tomatolog commented Jan 30, 2019

issue was fixed at f3c7848 . You could build any master version above that and replace searchd to get issue fixed or it will be published at next release.

@tomatolog tomatolog added the Resolved label Jan 30, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.