Update system requirements for 2.0 #960

Merged
merged 4 commits into from Dec 5, 2016

Projects

None yet

2 participants

@dregad
Member
dregad commented Nov 26, 2016

Proposal following discussion in #21841

@dregad
Member
dregad commented Nov 26, 2016

Regarding browser requirements, I went for a minimalistic approach. This is fully open to discussion.

  • FF 45 because that's what the current ESR version is based upon
  • IE 10 because anything to avoid known issues with older versions (was even tempted to set 11 but was not sure if it was necessary to be too restrictive)
  • Other browsers did not specify any versions before, not sure if we should define one now

I googled a bit, and it seems that most systems / libraries out there tend to support whatever the "current" version is, as well as "current - 1". That is probably too restrictive for us, but I'm not quite sure what we should recommend as a minimum version.

@syncguru your feedback would be appreciated

@vboctor
Member
vboctor commented Nov 26, 2016

@dregad I would merge this and then we can tweak later. I would go with IE 11. The issue is that as we use javascript libraries, supporting older browsers can be a pain.

@dregad
Member
dregad commented Nov 26, 2016

@vboctor If there are no objections, I'd suggest to merge this prior to releasing 2.0.0-rc.2

@dregad
Member
dregad commented Nov 26, 2016

X-post 😉

dregad added some commits Nov 26, 2016
@dregad dregad Doc: update system requirements for 2.x
Fixes #21841, #21965
b1a77d2
@dregad dregad Doc: update client (browser) requirements for 2.x 2d99a5d
@dregad dregad Doc: set version to 2.0 and reset revision history 19db6f8
@dregad dregad README: update requirements for 2.x
5a5bf09
@dregad dregad merged commit 5a5bf09 into mantisbt:master Dec 5, 2016
@dregad dregad deleted the dregad:min-req-20 branch Dec 5, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment