A node wrapper for fuzzy-phrase
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
bench
cloudformation
lib
native
scripts
test
.editorconfig
.gitignore
.travis.yml
README.md
package-lock.json
package.json

README.md

Node Fuzzy Phrase

Node.js wrapper using Neon for the fuzzy-phrase Rust module.

Install

To install node-fuzzy-phrase run:

npm install

By default, binaries are provided for 64 bit OS X >= 10.8 and 64 bit Linux (>= Ubuntu Trusty). On those platforms no external dependencies are needed.

Other platforms will fall back to a source compile: see Source Build for details

Source build

  • To build from source run: yarn build || neon build. This will automatically build the binaries.

  • To do a full rebuild run: neon clean

Publishing

This project includes script/publish.sh which builds binaries and published them to s3.

  1. Merge your branch into master
  2. Update version number in package.json
  3. git commit -m 'releasing 0.1.0 [publish binary]'