Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

npm install of 4.0.7 failed on linux (debian 9-stretch) #1161

Open
getify opened this issue May 8, 2019 · 4 comments

Comments

Projects
None yet
2 participants
@getify
Copy link

commented May 8, 2019

I am using node@12.2.0 and npm@6.9.0.

I installed the newly released 4.0.7 on my Mac OSX 10.14, and it worked fine. Then I tried to install it on my Debian 9-Stretch server and I got an npm error.

npm reported this:

npm ERR! code ERR_INVALID_OPT_VALUE
npm ERR! The value "false" is invalid for option "readableHighWaterMark"

Here's the full npm debug log: https://pastebin.com/0BFuJzHb

@kewde

This comment has been minimized.

Copy link
Collaborator

commented May 8, 2019

Hi,

I can not replicate this, I'm running Debian 9 as well.

user@host:~/projects/mapbox/node-sample$ cat /etc/os-release 
PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
NAME="Debian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"


user@host:~/projects/mapbox/node-sample$ nvm install 12.0.0
Downloading and installing node v12.0.0...
Downloading https://nodejs.org/dist/v12.0.0/node-v12.0.0-linux-x64.tar.xz...
######################################################################## 100.0%
Computing checksum with sha256sum
Checksums matched!
Now using node v12.0.0 (npm v6.9.0)


user@host:~/projects/mapbox/node-sample$ nvm use 12.0.0
Now using node v12.0.0 (npm v6.9.0)


user@host:~/projects/mapbox/node-sample$ npm install sqlite3
> sqlite3@4.0.7 install /home/user/projects/mapbox/node-sample/node_modules/sqlite3
> node-pre-gyp install --fallback-to-build
node-pre-gyp WARN Using request for node-pre-gyp https download 
[sqlite3] Success: "/home/user/projects/mapbox/node-sample/node_modules/sqlite3/lib/binding/node-v72-linux-x64/node_sqlite3.node" is installed via remote
npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN sample@1.0.0 No description
npm WARN sample@1.0.0 No repository field.

+ sqlite3@4.0.7
added 113 packages from 102 contributors and audited 160 packages in 77.418s
found 0 vulnerabilities

I've tried 12.2 in a completely fresh directory as well and was not able to replicate this :/ .

@getify

This comment has been minimized.

Copy link
Author

commented May 8, 2019

On this same Debian machine, I am able to build from source (master) but not able to install via npm.

@kewde

This comment has been minimized.

Copy link
Collaborator

commented May 8, 2019

I suppose you have already tried this but does removing the node_modules and calling npm install help?

@getify

This comment has been minimized.

Copy link
Author

commented May 9, 2019

When I delete node_modules and do npm install sqlite3, I still get a failure to install, but this time it's a different error. I've reported it (against npm) here: https://npm.community/t/failure-to-install-a-package-log-says-its-an-npm-error/7375

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.