0.6.6 silently dropped support for node-mapnik 0.7.x #78

Closed
strk opened this Issue Feb 26, 2014 · 3 comments

2 participants

@strk

Travis was using 0.6.5 successfully with node-mapnik 0.7.26 but on publishing of 0.6.6 (and thus automatic upgrade) an error started to raise:

/home/travis/build/CartoDB/Windshaft/node_modules/tilelive-mapnik/lib/mapnik_backend.js:13

mapnik.register_default_input_plugins()

^

TypeError: Object #<Object> has no method 'register_default_input_plugins'

See https://travis-ci.org/CartoDB/Windshaft/jobs/19661147#L1336

The changelog only says support was added for 1.3.2, nothing about dropping support for older versions: https://github.com/mapbox/tilelive-mapnik/blob/v0.6.6/CHANGELOG.md#066

@springmeyer
Mapbox member

thanks, tagged v0.6.7 which should fix.

@strk

Thank you, builds restarted and travis confirms.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment