Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Tiles don't shown up when accessed remotely #1248

Closed
atrawog opened this Issue · 4 comments

5 participants

@atrawog

I'm running Tilemill as an Ubuntu Service with the following /etc/tilemill/tilemill.config

{
  "files": "/usr/share/mapbox",
  "server": true,
  "listenHost": "0.0.0.0"
}

Starting with Tilemill 0.9 no tiles show up when viewed from a remote host via web browser, because Tilemill tries to fetch them from the location http://localhost:20008/tile

@yhahn
Admin

Yes, please add the following lines

"coreUrl": "example.com:20009",
"tileUrl": "example.com:20008"

Where example.com is the domain name you'd like to have TileMill point URLs at. If you're running TileMill behind a proxy like nginx you can also adjust the port accordingly.

I'll look for an appropriate place in the docs to make note of this.

@atrawog

Thanks a lot, that does fix the issue.

I'm getting strange Unknown option errors, but beside that it works without a problem.

Note: Unknown option "listenHost" in config file.
Note: Unknown option "tileUrl" in config file.
Note: Unknown option "server" in config file.
Note: Unknown option "listenHost" in config file.
@tmcw tmcw closed this
@springmeyer
Admin

also docs have more info on this now: http://mapbox.com/tilemill/docs/guides/ubuntu-service/

@maelp

I have the same errors but it does not redirect to my host and when accessing behind the proxy it still says localhost:20008 rather than hostname:20008

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.