Permalink
Browse files

remove backward compatibility with python 2.6

this makes things smoother and we might never need to deploy the server
on py2.6 anyway
  • Loading branch information...
1 parent b986250 commit 48cb6a765a9871831e11840f8965038deb6a7b68 @mapleoin committed Apr 12, 2012
Showing with 2 additions and 11 deletions.
  1. +0 −3 .travis.yml
  2. +1 −4 popcorn/test/test_models.py
  3. +1 −4 popcorn/test/test_views.py
View
@@ -1,13 +1,10 @@
language: python
python:
- - 2.6
- 2.7
install:
- pip install -r pip-requires --use-mirrors
- pip install pep8
- # unittest2 is only required for testing on 2.6
- - pip install unittest2
before_script:
- psql -c "CREATE DATABASE popcorn;" -U postgres
@@ -26,10 +26,7 @@
from datetime import date, timedelta
import sys
-if sys.version >= '2.7':
- import unittest
-else:
- import unittest2 as unittest
+import unittest
from sqlalchemy import create_engine, event
from sqlalchemy.exc import IntegrityError
@@ -26,10 +26,7 @@
import sys
import gzip
import cStringIO
-if sys.version >= '2.7':
- import unittest
-else:
- import unittest2 as unittest
+import unittest
from sqlalchemy import create_engine, event

0 comments on commit 48cb6a7

Please sign in to comment.